Subaru Legacy Forums

Subaru Legacy Forums (
-   Warranty Issues & Problems (
-   -   remote won't lock/unlock car, then works (

malimx6 02-13-2010 12:23 PM

remote won't lock/unlock car, then works
I had this weird issue today. I went inside the store and locked the car with remote. I don't remember if it beeped but it did lock the doors, I'm pretty sure it beeped too. Anyway, I came out and remote doesn't work (no beeping and won't lock/unlock doors). Somebody brought me my spare keys and remote and same thing. I decided to unlock driver door with a key (I was afraid factory alarm will go off but it didn't) and got inside the car, started the car fine. I turn it off, close the door and tried to lock, nothing, it didn't work. I start the car and drive home, park it in garage, tried locking the doors and it works! Wtf?
I did have problems with battery because I didn't drive the car for couple of months. I cleaned the battery terminals yesterday and battery is fine now, but this problem occurred for the first time today, I never had this problem.

Any ideas??


edit: Forgot to mention, it's 2005 Legacy GT Ltd. MT

malimx6 02-13-2010 07:28 PM

anybody? any ideas?
another thing i should mention, my car is stock except HIDs which shouldn't affect security system or central locking system
odometer reads 63K km

joeleodee 02-13-2010 08:23 PM

You're battery is probably just dying. You were not clear if you got a new battery or not. If not, get a new battery and if the problem persists, report back.

malimx6 02-15-2010 10:00 AM

old battery is fine...i thought initially it was dead, but after cleaning battery terminals car is starting up fine. When i had that problem with central locking system in front of store, i was able to start the car w/out any problem. Turned off the engine and tried locking the car with remote and it wouldn't work!!! started the car again, drove home then tried locking the car with remote and it worked. That was couple of days ago now, and i haven't had that problem yesterday.

thx for your reply
anyone have any idea why this happened?? I'll let you guys know if this happenes again, obviously...

convrty 02-15-2010 02:14 PM

I have an 08 Legacy limited and my wife has been complaining about this for a while, it happened to me two days ago. It seems to happen when it is cold, below 35 degrees and raining or snowing. It seems to have something to do with temp or humidity sounds wierd but that is when it acts up the most. I am going to the dealership at the end of the week they replaced the batteries last month in the remotes I'll see what they say.

malimx6 02-15-2010 10:38 PM

hmmm weird...i heard it could be rf interference, that is, if there is a lot of interference in that spot. I've been in that store before with all my cars and never had that problem, even with my legacy, therefore i personally don't think this is the issue. Also, battery is working fine. I never had this problem before, i've had problems with gremlins in my stereo, but not this!
Also, battery in remote is not the issue either since i tried opening with my spare remote (which i never used but it does work) and wasn't able to.

EquinnoxX 02-17-2010 01:40 AM

Mine is and pretty much has been intermittent at times since I got the car in 07. I always assumed it was the battery but was too lazy to change it.

I'll either give it a minute or two before I try it again, or smack the remote a few times on my hand. That will usually get it working again for another 3 months :rolleyes:

convrty 02-17-2010 03:59 PM

I have an 04 Tundra and park at all the same places and never had any trouble with it it even has awesome range. Just a Subaru thing from what I can see.

PeterJMC 02-17-2010 04:04 PM

My '06 does this. It mostly happens when it's cold/rainy outside. I've even been standing right next to my car and the FOB hasn't worked.

It's not a low battery issue in the FOB because it's done this even with new batteries. I've also adjusted the connectors in the FOB to ensure they are making good contact with the battery and it hasn't resolved the problem.

convrty 02-20-2010 04:25 PM

I had to move the appointment to Monday, but the Service Advisor did say they have known frequency interference, video servelance like at WalMart and the malls are the worst. Subaru has a built in code reader blocker, if it picks up frequencies like someone scanning to get in your car it disables itself for a few minutes then makes sure it is clear before it reenables itself??? Sounds like it could be true but over secure. :confused:

mattg 02-20-2010 04:35 PM

I had that happen over the holidays, only at night and only in front of my house. I ran in and grabbed my 2nd remote which I have only used a handful of times, and it wouldn't work either.

Strangely enough I think it was some sort of interference. It seemed to coincide with my neighbors Christmas lights being on. Hasn't happened since the holidays.

psucaptainkickass 02-22-2010 09:14 AM

My money is on interference, but also the battery could be an issue.
This is what happened to me:
I had this issue for the longest time.
I decided to get my battery checked since it was winter and 4+ years old. Anyways, while the car would turn over fine, the battery tester said it was a bad battery, so I decided to get a new battery.
With the new battery my remote works just fine again, however, at the parking lot of the gym I go to, it has the hardest time working. My money is on interference. As someone mentioned, maybe its a CCtv thing...the lot I park at is shared with a bank, so I wouldn't be surprised if there are video cameras all over the place.

malimx6 02-23-2010 08:57 AM

thx for all replies...
i haven't had any problems starting up my car nor remote issues. Hopefully it was just some interference issue...i will post back if it happens again

LosAngelesLGT 02-23-2010 09:28 AM


Originally Posted by malimx6 (Post 2841650)
thx for all replies...
i haven't had any problems starting up my car nor remote issues. Hopefully it was just some interference issue...i will post back if it happens again

For sure! That is pretty wierd and would be interesting to know where the interference came from.

When it happened to me, it was unclean terminals combined with an aging battery.

Wang Lung 02-23-2010 09:55 AM

I work at a strip mall every Saturday night. My remote works so poorly there, I just lock/unlock manually.

All times are GMT -6. The time now is 11:21 AM.

vBulletin Optimisation provided by vB Optimise v2.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.