Subaru Legacy Forums

Subaru Legacy Forums (https://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (https://legacygt.com/forums/forumdisplay.php?f=10)
-   -   What's your most embarrassing Legacy DIY mistake? (https://legacygt.com/forums/showthread.php?t=177708)

spc2125 10-03-2012 06:02 PM

Quote:

Originally Posted by Haight 05LGT (Post 4098908)
You are such a dork. You would know what they were for if you just asked the tuner. haha. I have to use them for opensource tuning.

Sorry I dont tune my car and have not encountered them before...

a93x 10-03-2012 06:09 PM

Quote:

Originally Posted by Haight 05LGT (Post 4098908)
You are such a dork. You would know what they were for if you just asked the tuner. haha. I have to use them for opensource tuning.

Didn't notice them until a day or so after and wasn't so worried about it

bucko3the7man 10-03-2012 06:30 PM

On my old 94 sentra, I changed the oil for the first time and it went fine. The 2nd time however, I had CRANKED on the oil filter and as you can guess, it was stuck on there like crazy. I had to get it towed to my mechanic after trying everything I could think of, including shoving a screwdriver through it and trying to twist it off like that. I stopped tightening them too much after that.

zenfamily 10-03-2012 06:35 PM

Not replacing the oil discharge hose on the turbo, which ruptured and caused a fire. The oil that was dripping was aflame. I had to put it out with a firehose.

joeleodee 10-03-2012 06:37 PM

When installing the EWG, I forgot to install the valve seat. When I started the car, it sounded like I was running open headers. It hit me at that point. "Shit, forgot the damn valve seat!" :lol: No harm done, though. Just time lost.

That Guy 2-1 10-03-2012 06:40 PM

Was torquing the first head down and misread in-lbs as ft-lbs, wasn't thinking straight due to being pissed off with some other shit and broke one of the outer bolts. Dang!!! Machine shop gave up trying to get it out after breaking a punch in there (it was two inches in there and sheared at an angle) so thought I needed a whole new block. Got it home, put a 1/4" drive chrome socket that exactly fit the counterbore down the hole backwards and used the 1/4" drive square hole as a guide to center a 1/4" drill bit and just pecked at the middle of the sheared bolt for a long time until it created a nice dimple. Then took a pilot point drill bit the size of the counterbore and used the dimple as a center punch mark to carefully shave away the tip of the bolt and make it a flat surface. Then took a reverse drill bit from my extractor set and went at it and it snagged at one point which made it break the bolt loose and bring it out!!! Glad I had these tools, else i'd have been $600 in the hole and my wife wife would have tried to get me 6 feet down the hole! lol

thefultonhow 10-03-2012 06:53 PM

Quote:

Originally Posted by F1inspiredLGT (Post 4098813)
I made the mistake of draining my coolant into 5 qt empty oil containers. Then placing the containers next to the new oil containers. Guess what happened next.



Yup, went to top off the oil one day with used coolant. Had to flush the system after that one. Lesson learn, place used oil/coolant on the other side of the garage.

I put blue painter's tape on all the containers in my garage that have used oil or coolant, because I know if I don't that I will do something similar. :cool:

Haight 05LGT 10-03-2012 07:05 PM

Quote:

Originally Posted by spc2125 (Post 4098932)
Sorry I dont tune my car and have not encountered them before...

I was talking about Nick. He should know better. I mean cmon his car is stage 3...ish

spc2125 10-03-2012 07:06 PM

Quote:

Originally Posted by Haight 05LGT (Post 4099054)
I was talking about Nick. He should know better. I mean cmon his car is stage 3...ish

Mine is stage 3 as well ... :p

a93x 10-03-2012 09:42 PM

Quote:

Originally Posted by Haight 05LGT (Post 4099054)
I was talking about Nick. He should know better. I mean cmon his car is stage 3...ish

3.5 actually.

spc2125 10-03-2012 10:22 PM

Quote:

Originally Posted by a93x (Post 4099281)
3.5 actually.

What even is .5? hahaa

a93x 10-03-2012 10:33 PM

Quote:

Originally Posted by spc2125 (Post 4099318)
What even is .5? hahaa

http://legacygt.com/forums/showthrea...ons-48123.html

Correction= stage 4

Built motor. All supporting mods.

Swansack 10-04-2012 09:28 AM

i stripped out the threads on the cold side of my turbo from taking off and reinstalling my intercooler too many times. decided that a helicoil was the best way to fix it, but i snapped the tap off in the housing. stupid. i tried backing it out with a chisel but it wouldn't budge. i tried all sorts of drill bits but they couldn't cut through the tap.

easy fix though...just bought a VF52 ;)

spec.B Dream 10-05-2012 01:42 PM

I too stripped out the turbo to IC threads and ended up with a BNR68.

asa5480 10-05-2012 02:37 PM

Cross threaded my new VF52 when installing the AVO TMIC. Decided that the cleanest route was to through bolt it. It's a little trickier to take apart and re-install, but it torques down nice and snug


All times are GMT -6. The time now is 11:58 PM.



vBulletin Optimisation provided by vB Optimise v2.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
LegacyGT.com