View Single Post
#12: 07-02-2013, 08:17 PM
 
 AZP Installs
AZP Installs's Avatar
Title: Tri-State Subaru Experts
Location: Kenilworth, NJ (Exit 138 GSP)
Car: 94LegTurb->92SVX->05 LGT->11 STi->14 BRZ
Posts: 4,848
iTrader: (10)
Send a private message to AZP Installs Find all posts by AZP Installs Reply With Quote
Quote:
Originally Posted by wadi23 View Post
thanks everyone i'll check the reservoir, and flush out everything make sure its clean. the fan is new the mishimoto 12inch recently installed and the water pump is brand new not even 6 months old.
to make the situation even trickier if i gradually ease up to the higher speeds its no problem it wouldnt over heat. When i "mash out" as we say down there then the needle moves and only after a while and when i'm approaching 180-200

the headgaskets cant be the prob, i have no hard starting, my oil and coolant is clean, no bubbles in the reservoir. I believe everything is properly torqued down.
You keep referencing 180-200? I'm confused.

Also new water pumps and fans have been known to have issues.

-Mike Paisan

AZP's First Private Track Event, June 19 at NJMP Thunderbolt $315 including Classroom and Mentor!

11+ Years Maintaining, Modifying and Educating TriState Subaru Enthusiasts.
Call directly as We carry almost every manufacturer now, so before you buy parts call us.

Like us on Facebook! | E-mail: sales@azpinstalls.com | 725 Fairfield Ave | Kenilworth, NJ 07033 | 908.248.AZP1 (2971) | T-1 Certified Amsoil Direct Jobber |AIM: AZP Installs
"Race Tested, Enthusiast Approved!"