View Single Post
#5: 01-15-2013, 10:56 PM
 
 killerniceguy
Title: Member
Location: Canada
Car: 2012 LGT
Posts: 179
iTrader: (1)
Send a private message to killerniceguy Find all posts by killerniceguy Reply With Quote
Quote:
Originally Posted by Scooby Fan View Post
I have mentioned a few problems with my OEM Nav system in other threads but I think this needs a thread of it's own. Mine is in a new 2012 Legacy 2.5 Limited and has been crap right from day one!! It has been to the dealer a few times now and the service guys say it is "Just fine" and they have never had complaints about the system at all.....the sales guys say they have been inundated with complaints since the system was introduced into Subaru's line up, both Legacys and Foresters.
I live in Burnaby which is a suburb of Vancouver BC

Here are just a few of my incidents starting back when it was new , 2 months ago.
- Used the GPS to take me to the dealership....it said I had "Arrived at destination" when I was still 4 Km away
- Used the GPS to go to one of my favorite golf courses (Just a test)......about 3 block from home it instructed me to "Turn right on Keele Street".....there is NO Keele Street in western Canada....it is in Toronto Ontario.
- Used it to go to a restaurant about 40 Km from home.....Out for lunch with my wife.... The GPS took us 7 Km past the town the restaurant is in and then doubled back through the town and finally to our destination....total 15 Km extra driving.
- Left home just last week with no plotted destination...just watching the displayed map.... I couldn't recognize any of the streets so I expanded the map to see where it thought I was at the time.....It had me driving through some houses in a suburb of Los Angeles,....not even on a street or road....finally put me on Hwy 101 in an area called Korea Town in LA. About 10 minutes later it switched to Vancouver area...as if it had just woken up!!

These are just a few of the worst incidents....I would say that even when it is working as well as it can it has an accuracy of about 60-100 meters and generally much worse.
I contacted Pioneer and they say this is unacceptable (No sh!t batman) and that Subaru should replace it....Subaru says it is fine because when they tested it, they took it a few blocks from the dealership and it found it's way back with no problem.
I found the GPS antenna wrapped in a bunch of wires inside the dash and moved it to a spot where it has a clear view of the sky and that seemed a bit better but the last incident was after I did that.

Let's hear some of your stories about this Pioneer nav system Nice stereo....garbage Nav system!!!

BTW .... I have already bought a Garmin Nuvi for the times I really need a reliable Nav.
Have you thought of going the CAMVAP route to see if you can get it replaced? If you can consistently replicate the problem I bet once you mention CAMVAP, they (subaru Canada) will just replace it with an aftermarket unit of your choice.