View Single Post
#7: 01-06-2013, 11:50 AM
 
 Kountz430
Kountz430's Avatar
Title: New Member
Location: Penndel Pa
Car: 97 legacy L, 94 Maxima, 90 Maxima,
Posts: 5
iTrader: (0)
Send a private message to Kountz430 Find all posts by Kountz430 Reply With Quote
Quote:
Originally Posted by monkeyposeur View Post
I'd clean your EGR valve (have a new gasket on hand when you reinstall it) and your check vacuum lines. Check your ground connection to your starter as well (although that wouldn't cause it to die while running) because that might be why it won't even click and your starter relay.

Probably wouldn't hurt to run a bottle of HEET injector cleaner. Other things to check would be the fuel pump, injectors, and ignition coil. You might have a few problems going on at once.

edit: On the passengers side of the engine bay is a vacuum line running from the passengers strut tower to the engine bay that has a small (quarter size in diameter), round filter on it. they are $7 from Subaru. Replace that as well.
post pics if u gottem i went out this morning to check my grounds and things of that nature,all that i can find seem to be in good condition nothing frayed or corroded.I also looked at and checked all of the vacuum lines. They all seem to be in good condition. i let the car warm up to o/t went for a quick ride and it stalled once but fired right back up How do you clean an egr valve and iacv (if at all possible to clean the iacv on these cars) never did before ive heard of people doing it before but never attempted it my self