View Single Post
#9: 12-21-2012, 07:36 PM
 
 itzed
itzed's Avatar
Title: Senior Member
Location: Fallston, Maryland
Car: 2006 Legacy SE - 5 Spd
Posts: 240
iTrader: (0)
Send a private message to itzed Find all posts by itzed Reply With Quote
Here's an update for future searchers. I passed the emissions test today, although I'm not sure how. Using the Torque app on my droid phone and a Bluetooth OBDII interface I bought on eBay, I cleared the code about a thousand miles ago. I kept track of the IM readiness and most of the tests were completed fairly quickly, but the following kept showing not ready: Reserved; Heated Catalyst; and A/C Refrigerant. Having done a good bit of research on the web, I assumed that it would not pass based on the Heated Catalyst test not being ready, and at least one article written by the Maryland emissions people themselves said that a faulty sensor could keep the test from actually running. So I bought a new rear O2 sensor on Amazon. Today I figured I had nothing to lose by taking it to the test first, and maybe in their last day before Christmas, they would have mercy on me and give me a gift of passing. Well, I made some good conversation with the tester during the whole process, and low and behold, it passed. I have no idea if it was a Christmas gift, or if Maryland doesn't care about the heated catalyst test, or if my Torque software is reading it incorrectly (I doubt it). But whatever, the light has not come back on since I cleared it, and I'm good for another two years as far as Maryland is concerned.