View Single Post
#1: 12-18-2012, 04:07 PM
Need some serious help with this big turbo/oil issue -
 
 Gforce3s
Title: New Member
Posts: 9
iTrader: (0)
Send a private message to Gforce3s Find all posts by Gforce3s Reply With Quote
I am getting extremely frustrated here with my 05 legacy gt build, and im hoping some of you can help. I picked this car up a year ago with a blown motor. Im an ASE Mastertech, and have built a few cars, never a subaru, but i figured it should be no issue. Ripped it apart, found a cyl 3 piston blown apart. So eventually what i ended up doing was going to fred beans and ordering a brand new assembled block, oil pump, timing belt kit, water pump, stock oil pump pickup. I sent my heads to my local machine shop for all new valves and to be nice and cleaned up. Re assembled the engine, no issues at all. Did a TGV delete, went with 740 injectors, upgraded fuel pump, 16G turbo from BNR. AVO top mount, cobb intake, megan racing header up pipe, catless downpipe, magnaflow turbo back. I removed the oil screens from the banjo bolts in the head, and i have an infamous performance upgraded oil line kit (the one with 3 lines not just 2). Primed the whole thing properly, broke the turbo and enigine in with non synthetic very gently for 650 miles. EFI Logics in CT did the tuning, made 318hp 336tq @18lbs. Drove it for 3 weeks, got to 1300 miles and all of a sudden out of nowhere, on the highway at cruse speed my turbo blows. So i take it off and send it back to BNR, he rips it apart and says it got ridicuously hot and is oil starved. Payed to have it rebuilt, got it back, replaced the AVCS valves yet again with oem subaru ones again, JUST to make sure. Had the turbo oil supply line off of the turbo (without the turbo on the car) and cranked it over, plenty of oil flow coming out in my opinion, but couldnt really check pressure there. Put the turbo back on, did everything again. Now its been about 600 miles, got a P0011 and the turbo sounds like its going to go any minute. Im at a loss. I feel like ive replaced everything possible and upgraded everything i could. Does ANYONE have any ideas on whats going on?
Sponsored links