View Single Post
#4: 12-14-2012, 08:24 AM
 
 SeeeeeYa
SeeeeeYa's Avatar
Title: Burning Monkey
Location: Charleston WV
Car: 2015 GBP CVT WRX Ltd
Posts: 2,165
iTrader: (14)
Send a private message to SeeeeeYa Find all posts by SeeeeeYa Reply With Quote
Quote:
Originally Posted by cryo View Post
Sub'd

Always good to see you posting seeya.

Arnt those tables exclusive to 07+ ecu's? Glad to see it helped in your situation though.

Dave
Good question. One would think that, like other things, Subaru may never have had a reason to address the fuel resonance problem "back then," and thus either the Load Compensation tables involved don't exist in early ECUs or have not been revealed.

Nevertheless, there is every reason to suspect that even earlier cars without those tables defined still have the same problem, that can be removed with the addition of one meter of FI hose. Nothing to lose, a LOT to win.

Those with the tables can see the resonances revealed by zeroing out the subject tables. Because ATR leaves untouched cells green, cells that have gone more positive red, and cells that have gone negative yellow, a pattern in color is revealed after zeroing the table.

I mentioned I ruined my OEM quick-connect short hose... I did that by trying to use a barbed connector. The trouble is, the new 5/16" hose is larger than the OEM line. In addition, the OEM line is lined... with a very unforgiving liner, that tears easily, potentially releasing pieces into the injector supply that could spell death to an engine if it blocks one. Just remove that section altogether, and install the new hose as I explained. (It goes without saying, but... I also made CERTAIN there was nothing in the new hose before I installed it.)