View Single Post
#14: 12-02-2012, 04:03 PM
Random extremely loud static
 
 Amicula
Title: New Member
Posts: 12
iTrader: (0)
Send a private message to Amicula Find all posts by Amicula Reply With Quote
I made a post about a month back (in the wrong sub-forum) about issues I've been having with the stock radio. Harmon Kardon speakers, automatic climate control.

It started off ONLY happening when turning the car on. Loud static would emit from every speaker and be so loud that your ears would ring afterwards. The only way to stop the noise was to turn the car off and back on.

It was happening weekly and thought I had narrowed it down to being the aux port, since my iPod was always plugged in. I spent the last two and a half weeks listening to nothing but the radio (painful) and had no issues with the static until I decided to listen to my iPod two days ago. I had no issues that day. The next day I had the radio back on and loud static came on while I was on the expressway.

I talked to a car audio installer and he suggested that my radio is most likely bad and that I would need to replace it to resolve the issue. Unfortunately I just don't want to spend the money to do so!!

In my previous post I received a suggestion to try an aux ground loop isolator and will be trying this to see if it resolves the issue. It has been ordered and is on the way, but I would like to know if anyone else has any suggestions or clues.

Thank you very much for your time and effort to help me resolve this issue! It's driving me nuts!