View Single Post
#10: 11-16-2012, 01:04 AM
 
 HAMMER DOWN
HAMMER DOWN's Avatar
Title: Duke
Rank: Premium Donator
Location: Tioga county ,NY
Car: 05 Legacy GT w/ STi 6MT~07 Solstice GXP
Posts: 2,128
iTrader: (0)
Send a private message to HAMMER DOWN Find all posts by HAMMER DOWN Reply With Quote
Quote:
Originally Posted by smitty69 View Post
Most likely the fact that I did not know I needed to replace the oil feed lines when I replaced the turbos. Clogged banjo filters led to oil starvation and turbo failure. Using a mechanic that does not work on many turbo vehicles was another mistake. Anyway, the new turbo has the correct IP&T oil feed lines, new OCV's, larger intercooler. So, it should be good now. I hope.

I'm glad your turbo has been holding up for so long, but if you review these forums you will realize that you are an exception, not the rule, for anybody with a vf40 turbo. Especially if you have staged your car at all.
Glad you got it figured out why. Did you " search", Failure on this site is around 25-28%. 3 turbos I beet is under.5%. The exception would be you. Not trying to get into a pissing match, but may car is driven hard daily.

My car, I tow with it, anything from full loaded 4'X8' trailer to 3500bls. cars on a tow dolly.

Stage 2 custom tune from Tuning Alliance, peek boost 18.5.

Over 100 runs down the drags strip. Best time 13.65@ almost 101mph.

OCI is 15k, banjo filter bolt as been in the oil lines up to 174k, then I removed both of them.

Last edited by HAMMER DOWN; 11-16-2012 at 01:17 AM..