View Single Post
#1: 11-08-2012, 06:44 AM
Suspension Guru's Mount Up...Another troubleshooting moment!!
 
 jhow257415
jhow257415's Avatar
Title: Member
Location: Albany,NY
Car: 2007 5MT
Posts: 138
iTrader: (3)
Send a private message to jhow257415 Find all posts by jhow257415 Reply With Quote
OK soooooo I read about this on several forums with very few remedies if any! Purchased the Kartboy front and rear sway bar end-link combo kit recently. Just noticed today that with the steering turned wheel (completely/fully turned) to the left or to the right there is noise contact with the tie rods (metal on metal) and the end links. There is also a consequential grinding noise! My car is stock suspension other than the bar…has NOT been lowered or altered in any way than the bar. My sway bar is Rallitek (Non-Turbo). The top of the endlink/swaybar connection point is rubbing the bottom of the tie rod. This is happening on both sides. Anybody have this problem? What was done to fix it?
Attached Thumbnails
Click image for larger version

Name:	1 Screen Shot 2012-11-08 at 8.34.49 AM.png
Views:	37
Size:	448.6 KB
ID:	133390   Click image for larger version

Name:	2 Screen Shot 2012-11-08 at 8.35.38 AM.png
Views:	39
Size:	413.9 KB
ID:	133391   Click image for larger version

Name:	3 Screen Shot 2012-11-08 at 8.33.58 AM.png
Views:	33
Size:	399.5 KB
ID:	133392  

Click image for larger version

Name:	4 Screen Shot 2012-11-08 at 8.36.21 AM.png
Views:	37
Size:	433.5 KB
ID:	133393   Click image for larger version

Name:	5 Screen Shot 2012-11-08 at 8.36.44 AM.png
Views:	47
Size:	393.1 KB
ID:	133394   Click image for larger version

Name:	6 Screen Shot 2012-11-08 at 8.40.52 AM.png
Views:	34
Size:	127.2 KB
ID:	133395  

Click image for larger version

Name:	7 Screen Shot 2012-11-08 at 8.42.22 AM.png
Views:	36
Size:	264.2 KB
ID:	133396  
Sponsored links