Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Can't Shift Out of Park (http://legacygt.com/forums/showthread.php?t=63479)

grantmilo 06-06-2007 11:18 PM

Can't Shift Out of Park
 
Ok, you know that safety lock that keeps you from shifting out of park without pressing down the brakes first? Mine's gone haywire! I mean, the car runs fine, but won't let me shift out of park. Seems to get worse in cold weather, but sometimes does it on hot days too. Today I waited 15 mins before the thing finally released. I took it to the mechanic and he said "I can't diagnose it unless it's acting up right now." But obviously when it's acting up I can't get it to the mechanics, cause it won't move. He also said to listen for a click while pressing slowly on the brakes... so I did, but I didn't hear any click. If I just knew where this safety-lock-thingy is, I'd fix it myself. Probably just full of dirt or something, right? Or couldn't I just disable the darn thing? It's a '94 by the way.

meier motor sports 06-06-2007 11:28 PM

its usualy by the shifter itself.do you hear it click n the times that you can shift out of park? if so hunt down the click. thats what has stoped working. its called the park shift interlock.

grantmilo 06-07-2007 12:18 AM

It never clicks when pressing the brakes. However, when the button does work, there's a click coming from behind the steering wheel. Could the park shift interlock be behind the steering wheel? :confused:

meier motor sports 06-07-2007 06:25 AM

could be. i can try looking up some info at work today if i remember

snorris01 06-07-2007 06:44 AM

FWIW, my wife's '05 Baja Sport AT blew the fuse for the brake lights due to a bad rented cargo trailer. That caused the transmission to not be able to taken out of park at all.

I don't know if the systems are similar at all, but it may be worth checking your taillights when you are getting the problem. You may be getting a short like we had.

Opie 06-07-2007 07:24 AM

+1 Check the taillights first, if they aren't working when you press the brake you've narrowed your problem.

meier motor sports 06-07-2007 04:34 PM

there is a switch on the brake pedal for the park shift iterlock. and the park shift interlocker itself is by the shifter handel

normality78 02-18-2013 01:45 AM

Sorry to revive the thread just to give some input. Mine was 2.0 LGT. Happen to face the same issue just an hour ago.

After tried for 45 mins, the tow truck guy tried to pull the shifter up and shift and it work.

car_cursed 02-18-2013 08:41 AM

'94? How about asking these knowledgeable folk?

http://legacygt.com/forums/forumdisp...4-1998-95.html

normality78 02-20-2013 07:06 PM

Mine was 2005

RabidWombat 02-21-2013 09:30 AM

There's an override next to the shifter. Pop the circular plastic cover and use a screwdriver to push it down. Its actually listed in the manual.

Andrewxxcarlson 02-21-2013 12:54 PM

There's usually a shift solenoid in the center console, test with a multimeter. Happened on a buddies tl.


All times are GMT -6. The time now is 01:01 PM.


LegacyGT.com