Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Second Generation Legacy (1994 - 1998) (http://legacygt.com/forums/forumdisplay.php?f=95)
-   -   Need some help (http://legacygt.com/forums/showthread.php?t=208904)

DGR81 06-06-2013 07:44 AM

Need some help
 
:confused: While I was driving I notice there was some smoke coming from the hood. I turned around and went into a gas station. I pop the hood and saw the antifreeze leaking a little so filled up but not much. Then when I tried to start it. It would pop a bit than die out but when I rev the engine it would run fine. Any ideas on what the problem could be??????

DGR81 06-06-2013 06:10 PM

Does anyone have an idea?

Kennyfvholla 06-06-2013 06:12 PM

The connections on your MAF sensor plug may have gotten wet. Check, clean, re-install and then see if it still acts the way it is now.

DGR81 06-06-2013 06:44 PM

What about the IAC?

Stang70Fastback 06-06-2013 06:55 PM

Actually, if it stalls out when you start it, but works fine when you give it some gas, it may very well be the IACV, as that suggests it might be stuck closed, so the engine only gets air when you open the throttle body yourself.

Kennyfvholla 06-06-2013 07:03 PM

It could be the IAC. I just remember a time when my engine compartment got wet and the engine started acting the same way. The connection for the MAF didn't like being wet.

Go ahead and check both.

twisty 06-06-2013 07:57 PM

could be a vacuum leak near the TB area as well.

DGR81 06-06-2013 10:03 PM

I'm wondering why the overflow bottle was over flowing with antifreeze?

Stang70Fastback 06-06-2013 10:11 PM

Yeah, that's not really a MAF or an IACV issue. That sounds more like a head gasket issue...

Kennyfvholla 06-07-2013 08:49 AM

That is definitely not what was asked in the OP...

Yes, the overflow reservoir overflowing is a very strong link to failing head gaskets. I've never seen it overflow otherwise.

purebluedoor 06-07-2013 09:17 AM

Makes me wanna waterproof my engine bay. Anyone made a write up or what main parts to start?

DGR81 06-07-2013 09:32 AM

I check the oil and I didn't see any antifreeze in it.

Zues Marine 06-07-2013 11:18 AM

Quote:

Originally Posted by purebluedoor (Post 4460940)
Makes me wanna waterproof my engine bay. Anyone made a write up or what main parts to start?


Kennyfvholla 06-07-2013 12:23 PM

Quote:

Originally Posted by DGR81 (Post 4460964)
I check the oil and I didn't see any antifreeze in it.

You will NEVER find coolant/water/antifreeze in the oil. The gaskets don't leak that way. The ring that seals the cylinder bore to the head fails, allowing the ignited fuel/air to escape the combustion chamber, super heating the coolant. This is why the car overheats, because the cooling system can't cool the coolant as quickly as it is super heated.

DGR81 06-07-2013 01:30 PM

I found out it was the water pump and the timing belt skipped.


All times are GMT -6. The time now is 07:48 AM.


LegacyGT.com