Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Car troubles: CEL codes p0171 p0133 and p0303... any ideas? (http://legacygt.com/forums/showthread.php?t=206819)

Giovonage 05-01-2013 05:02 PM

Car troubles: CEL codes p0171 p0133 and p0303... any ideas?
 
So my car just started reading out p0171 (system too lean?), p0133 (o2 sensor slow response?) and p0303 (cylinder misfire?) codes. Oh and it seems to be a bit down on power, especially when the turbo kicks in
Im guessing the problem is the 02 sensor but after looking through the forums I'm hesitant to spend $150 on a new one, since most of the time it isn't really the problem. Any suggestions?

chato 05-01-2013 05:05 PM

you can try pulling the o2, inspect wiring and unit for damage and soak it in gasoline overnight to clean it.

4CEF3D 05-01-2013 09:07 PM

Depending on Where you are in socal you can pop mine in and see what happens. Its easy. But the misfire code is confusing me.

06silvarubiLGT 05-02-2013 06:24 AM

^If its running lean enough it will misfire. Have you ever done the TGV O-rings?

Max Capacity 05-02-2013 11:25 AM

From what I learned on here the front O2 sensor is the one that mess's with the fuel mixture.

You may want to replace that one first.

Then clean the MAF sensor with the cleaner for it, then think about getting the car tuned and off the OEM map.


Check out Mike's "m sprank" site, www.infamousperformance.net He can guide you on what you should do.

Giovonage 05-05-2013 01:23 PM

Quote:

Originally Posted by Max Capacity (Post 4414599)
From what I learned on here the front O2 sensor is the one that mess's with the fuel mixture.

You may want to replace that one first.

Then clean the MAF sensor with the cleaner for it, then think about getting the car tuned and off the OEM map.


Check out Mike's "m sprank" site, www.infamousperformance.net He can guide you on what you should do.

Awesome, thanks!

Giovonage 05-05-2013 01:25 PM

Quote:

Originally Posted by 06silvarubiLGT (Post 4414173)
^If its running lean enough it will misfire. Have you ever done the TGV O-rings?

Yeah it's definitely missing because of the lean fuel mixture. And to my knowledge the O-rings have never been done. I've realized that the original owner of the car never did ANY maintenance on it, so I'm having to replace pretty much everything...


All times are GMT -6. The time now is 08:43 PM.


LegacyGT.com