Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Third Generation Legacy (1999 - 2004) (http://legacygt.com/forums/forumdisplay.php?f=96)
-   -   03 2.5L GT manual HELP! (http://legacygt.com/forums/showthread.php?t=203999)

HawkGT647 03-20-2013 10:34 AM

03 2.5L GT manual HELP!
 
I just bought this car a couple weeks ago and I'm really regretting it! Hope you guys can help me out.

The car has 127k miles 2.5L GT with a 5spd man. I have only put about 130 miles on it since I bought it.

I was going to take a 1.5 hr trip but never made it. I was driving on the highway about 70-75mph for about 10 miles to my first exit. I pull off exit and I'm slowing down for stop sign ahead. I down shift and car starts running rough. Like I has hitting rumble strips. It was sputtering almost like it was mis-firing. Meanwhile shortly before this my speedo a odo stopped working and CEL came on.

Called the dealer I bought it from, gave him a piece of my mind and took it to a "subaru specialist"

Subaru guy said it was speed sensor. Says he's got some laying around in his tool box.:rolleyes: He installs speed sensor and I go pick it up. I don't even get a mile down the road and speedo goes to zero and soon after CEL came on.

I'm pissed! Drove it about 5 miles before I took it back to see if it would run rough again. I was hitting 4.5k in every shift and every time it hit 4.5k rpm the car would cut out like i was hitting rev. limiter. I'd slow down, drop to 4th, hit the gas and I could hear a different tone in exhaust like it was a deeper sound while climbing up to 4.5rpm before it would cut out. I'd shift to 5th.

now he is waiting for a new speed sensor to put in! He's had it for almost 2 weeks. and from the sounds of it putting old/used parts in my car. I'm no car tech but how does a speed sensor cause the car to run like dog poo? I'm thinking there is more to it than that.

What do you guys think? I fell this "specialist" isn't much of anything.

c-lo 03-28-2013 06:24 AM

bump

HawkGT647 03-28-2013 06:29 AM

Thank you much, c-lo!

coreyh29645 03-28-2013 06:35 AM

intersted in hearing how this turns out.

c-lo 03-28-2013 06:53 AM

why does it take 2 weeks for a part to come in? I think your specialist is poo and doesn't sound like he knows what he's doing.

c-lo 03-28-2013 06:54 AM

where are you located?

coreyh29645 03-28-2013 09:08 AM

i'm a parts guy myself and i can tell you that short of having to get a part overseas, there is no way that 1 part takes weeks. even an O.E. part shouldn't take that long. i am an aftermarket guy but i have had to get gm parts from the west coast and it took 10 days on the slow train when gm was on strike in the late 90's.

rSTimpreza 03-28-2013 09:14 AM

I work Mercedes Benz parts commercial it only takes 3 days to get my parts from Germany

HawkGT647 03-28-2013 10:24 AM

I'm in western NY.

Car is done. I called this morning to see what was going on. The car has been done since last friday. The dude lost my number!!

He says he installed a new speed sensor and turned my rotors. He seems to think the vibration while down shifting/slowing down was cause possibly by my Anti-lock brakes locking up....oh boy!

I'm going to go pick it up tonight. We'll see how it does.

This guy isn't my specialist,LOL. just a guy that I have been referred to as a subaru only tech.


All times are GMT -6. The time now is 07:36 PM.


LegacyGT.com