Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Warranty Issues & Problems (http://legacygt.com/forums/forumdisplay.php?f=48)
-   -   Burning Rubber Smell... HELP (http://legacygt.com/forums/showthread.php?t=203512)

kikal8 03-13-2013 05:45 PM

Burning Rubber Smell... HELP
 
Ok... so my gf just got an 05 lgt with around 80k on it. beautfiul car. very clean. i read alot about turbo's going bad. so thats really all i was looking for when we test drove it. now after we drive it we get this little puff of smoke from the driverside of the engine but in the back towards the turbo. and it stinks like burning rubber. not oil. not coolant.

i havent been able to bring the car to work to put it up on a lift yet and its cold outside so im not about to put it on a jack and look. So before i take it in the work and put it on a lift im wondering if anybody has anything for me to check out once i do get it in the shop. I read about the axle boots ripping open and spraying everywhere. so im definitely going to look into that. other than that i have NO idea what would be causing a burning rubber smell. O AND BTW! the dealership just replaced the clutch and im assuming the TOB aswell. thank u all in advance and hope u guys have good news for me.

kikal8 03-13-2013 06:38 PM

ALSO!!! if there is anything that we should do or check regardless of this issue please let me know.

KCwagon 03-13-2013 09:00 PM

Torn CV boot on the passenger side is my guess. This boot cracks easily and will tear, sending cv grease all over the down-pipe. It smells horrible and smokes like crazy. Since it is by the turbo, most people assume the worst. This is an easy fix for the dealership as well as a good shop. Should not be more than $100 with labor and parts.


All times are GMT -6. The time now is 02:44 AM.


LegacyGT.com