Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   2nd engine in 5000miles??? Wtf!!!??!!??! (http://legacygt.com/forums/showthread.php?t=203351)

05wagongt 03-11-2013 07:02 PM

2nd engine in 5000miles??? Wtf!!!??!!??!
 
bought my car with 47k used....engine blew on drive home, after 5-6 weeks I ha new engine in my car-a brand new, never used engine other then break in....

Then I hear a loud tapping yesterday coming from the timing chain cover....I take off cover and still hear it...

Long story short. I threw a rod? Wtf?? Engine only has 5k on it!!!

So I've owned my car since dec 1st and am going to be getting my 2nd engine???

I know there are issues with our cars, but not like this.....I am so ready to sell it and be gay like all the Honda boys and get a boosted b18 hatch that will actually last longer then an oil change!!! I'm so f----n pissed right now!!!

BarManBean 03-11-2013 07:14 PM

:(

ericem 03-11-2013 08:40 PM

Its simply bad workmanship its pretty crappy to read shit like this.

Gire 03-11-2013 08:48 PM

That's awful. No idea why...

Max Capacity 03-12-2013 08:00 AM

Quote:

Originally Posted by ericem (Post 4335203)
Its simply bad workmanship its pretty crappy to read shit like this.

We need more back ground info.

Did the previous owner have a turbo blow, traded the car in, the dealer just through in a new short block and sold the car at auction.

copenhagen6123 03-12-2013 10:49 AM

Who did the work for you?

chato 03-12-2013 11:21 AM

read Strizzy's thread. it will make you feel better.
http://legacygt.com/forums/showthrea...ld-143962.html

AkumaMax 03-12-2013 11:31 AM

if it's OEM you might still have a warrant through SUBARU on it. This is also one of the reasons I bought an aftermarket warranty for my car. I am on my 4th engine Owned the car since 09.

paintpollz 03-12-2013 12:28 PM

Quote:

Originally Posted by AkumaMax (Post 4336107)
if it's OEM you might still have a warrant through SUBARU on it. This is also one of the reasons I bought an aftermarket warranty for my car. I am on my 4th engine Owned the car since 09.

Then you and OP have really shitty mechanics because that is completely unacceptable. Sorry to hear this.

05wagongt 03-12-2013 12:39 PM

Quote:

Originally Posted by Max Capacity (Post 4335718)
We need more back ground info.

Did the previous owner have a turbo blow, traded the car in, the dealer just through in a new short block and sold the car at auction.

i bought the car with 47k, and the engine blew driving it home....engine was replaced and back in my driveway end of january....the new engine is the one that broke again...it was a brand new engine, not rebuilt...

05wagongt 03-12-2013 12:41 PM

garage did different tests today, no metal in oil, compression is good on all cylinders except #2... that is where my problem is... turbo is fine, so i am waiting to hear next step....

Max Capacity 03-12-2013 02:59 PM

Did they replace the oil pump and oil cooler or use the ones from the old engine ?

Were the heads cleaned and rebuilt ?

solidkevlar 03-12-2013 05:26 PM

47 k oil pump and oil cooler should be good? right come on.. no beef with max...

RabidWombat 03-12-2013 07:59 PM

Quote:

Originally Posted by solidkevlar (Post 4336760)
47 k oil pump and oil cooler should be good? right come on.. no beef with max...

Except for the metal fragments that get left behind when the turbo barfs into the engine...there's a huge thread on NASIOC about it...

05wagongt 03-13-2013 04:48 PM

it was new oil pump and cooler, and a new turbo.... new timing belt, even had new serpentine belt and hoses with it....


All times are GMT -6. The time now is 08:32 PM.


LegacyGT.com