Subaru Legacy Forums

Subaru Legacy Forums (
-   Fourth Generation Legacy (2005 - 2009) (
-   -   Car wont start (

Tehnation 03-11-2013 06:15 PM

Car wont start
I got an er hc after my maf wires got burnt up. I fixed the wires and the er hc went away but still wont start. On side of road now, any help would be appreciated.

Tehnation 03-11-2013 07:13 PM


Tehnation 03-11-2013 08:19 PM

How do I know for sure if my ecu is shot? This er hc came back?

Max Capacity 03-12-2013 09:25 AM

Did a web search for "er hc" and found this.

ErHc indicates a problem (“Error”) in the high-speed LAN communications system.

I don’t know if the absence of the symptom after the restart means it was just a short-term glitch. Perhaps the on-board diagnostic system keeps a record that can be accessed to verify this.

01-13-2007, 02:43 PM #3 (permalink)
Flying Cavalry

Join Date: Jul 2006
Posts: 100
Feedback Score: 0 reviews


Took it to the dealer, they're replacing the odometer assembly ...

There are other replys too. check them out.

Tehnation 03-12-2013 11:02 AM

Ive just about given up, its a short or blown ecu. Waiting for tow truck to send it to stealership.

heiche 03-12-2013 11:17 AM

u sure that the fuse labeled "SBF-7" isn't blown?

Tehnation 03-12-2013 12:38 PM

I had checked all the fuses and found nothing. 110 bucks for the stealership to tell me what it is.... stay tuned.

heiche 03-12-2013 01:05 PM

please post back, curious to know what it was. hopefully nothing too expen$ive.

chimaira4deth 03-29-2013 04:10 PM

any updates? friend of mine is going through the exact same problem

Tehnation 03-29-2013 04:54 PM

check sb7 fuse under hood

Tehnation 03-29-2013 04:54 PM

one of the big boxy ones

All times are GMT -6. The time now is 02:21 PM.