Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Second Generation Legacy (1994 - 1998) (http://legacygt.com/forums/forumdisplay.php?f=95)
-   -   idle issues (http://legacygt.com/forums/showthread.php?t=202743)

b20novtec 03-02-2013 07:39 PM

idle issues
 
my car seems top have a mind of its own some times idles correct and some times revs up to 1.5 some times 2 its a 1997 legacy wagon 2.2 new mass air and tps what else can it be oh yeah shows no codes

spooln30 03-03-2013 02:46 AM

IAC aka idle air control valve. They tend to get clogged with carbon and the door doesn't work properly. Remove it and clean with carb spray and reinstall it. It's located on the right side of the intake manifold right next to the throttle body.

DOHCEJ22E1 03-03-2013 03:23 AM

Easy Off or generic oven cleaner will do if you have nothing else.

snederhiser 03-03-2013 10:21 PM

Hello;
Sound to me like the new TPS was not installed correctly. The idle switch in not engaging in circuit! Check the factory manual for installation! The IAC also could be sticking, clean with carb cleaner. Steven.

b20novtec 03-04-2013 07:26 AM

thanks guys gonna try and clean the iac today let u guys noe how it goes

b20novtec 03-05-2013 09:53 AM

Seemed to work at first but after a drive on the highway back to the high reving

Sludgeroo 03-05-2013 10:43 AM

Where did you buy your tps from?

colby 03-05-2013 10:32 PM

you might want to check for a vacuum leak around the iacv maybe a longshot. break out some carb cleaner or whatever and spray around it and see if the idle changes

b20novtec 03-06-2013 06:42 AM

Quote:

Originally Posted by Sludgeroo (Post 4324442)
Where did you buy your tps from?



the tps was installed by the dealer along with the maf


All times are GMT -6. The time now is 11:54 AM.


LegacyGT.com