Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Turbo Powertrains (2.0GT, 2.5GT, 2.5XT) (http://legacygt.com/forums/forumdisplay.php?f=12)
-   -   Strange Noise over 10psi Boost (http://legacygt.com/forums/showthread.php?t=202688)

hoss 03-01-2013 09:15 PM

Strange Noise over 10psi Boost
 
I could use a little help diagnosing a new noise that my 05 LGT manual just developed. The car is stock except for running 93 octane stage 1 Cobb map.

Under heavy acceleration and once the boost hits 10psi or higher I hear a noise similar to party noise makers that unrolls whe you blow on it. It sounds like its coming from the drivers side of the engine compartment, not the turbo side. Besides for the noise over 10psi the car is running just fine...no power loss, no rough idle, etc.

Possibly an intercooler gasket leak? I'm not sure what else on that side of the engine compartment would make that sound under boost. I recently had my clutch replaced which I think requires the removal of the IC so this is the first thing I thought of.

Thanks in advance for any help.

Steve

tytek 03-01-2013 10:01 PM

Boost leak. Check your hoses and make sure they are on right and clamped down.

doobaruGT 03-01-2013 10:32 PM

It's the connection on the intercooler OPPOSITE the turbo. Just make sure it's snug in the hose. sometimes that worm clamp slips from oil blow-by and allows a leak. I had the exact same issue with mine and it sounded like a balloon letting out air slowly.

StoplightAssassin 03-01-2013 10:50 PM

It's the rubber coupler on the intercooler to throttle body hose. It's most likely torn or bent out of shape. Very common. Ditch the coupler and call it a wrap.

hoss 03-02-2013 09:30 AM

Thanks guys! I'll try to check it out this afternoon.


All times are GMT -6. The time now is 01:01 PM.


LegacyGT.com