Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Tuning (http://legacygt.com/forums/forumdisplay.php?f=84)
-   -   Cannot log WOT pulls (http://legacygt.com/forums/showthread.php?t=202559)

Cone_Killer 02-28-2013 07:04 AM

Cannot log WOT pulls
 
4 Attachment(s)
I have done tons of research on this problem with no fix yet. My issue is this; I can flash, use learning view and log normal driving without any issues. As soon as I try a WOT pull, it cuts out anywhere from 3-4.5k. When it cuts out, romraider says "connecting". So far this is what I have done to try and fix:

Load test battery (597 out of 600cca and 12.97v) its good
Check and clean engine grounds (two head to frame and the top of tranny)
Installed 3 ferrite magnets on the OBD harness before plug
Installed 1 ferrite on the vagcom cable after the OBD plug
Disconnected my phone charger
Turned the radio and A/C off

I have tried logging with vagcom and a Tactrix 2.0. I have also tried stand alone SD card logging with the Tactrix and it doesn't turn off but the data is sporatic and repeating. I have included a log from each style and posted them labeled accrodingly.

Any help would be greatly appreciated because I have to start this tune with Cryo.

iNVAR 02-28-2013 08:11 AM

OP knows this already, but for everyone else:

As I mentioned in the other thread, a whole bunch of people seem to have this issue too... Can't figure it out. And like I mentioned, I used to have this problem intermittently with an APv2 (silver dongle, sold it already) and my vagcom cable. The problem then completely disappeared with the vagcom after a while.

This guy just posted a thread about his AP having this problem:
http://legacygt.com/forums/showthrea...ot-202461.html

Strizzy 02-28-2013 02:31 PM

http://legacygt.com/forums/showthrea...es-179542.html

Cone_Killer 02-28-2013 02:53 PM

I read you're thread. You replaced the entire ECU? Was it reprogrammed for your key?

Strizzy 02-28-2013 03:03 PM

I found an ECU on car-part.com for $125 + shipping. I replaced my old ECU with it and reprogrammed my keys (I have access to Subaru's SSM tool if I ask nicely) with the codes on the small metal tags that came with my keys when I got the car. Flashed it with my map, started it up, and completed a log.

blongo804 02-28-2013 03:06 PM

Just encountered this problem today for the first time in my car using a Tactrix 1.3. Pretty upsetting and it better not happen again!!!

bnguyenbb6 02-28-2013 08:41 PM

I'm assuming that the connectors on the OBD2 port itself are wearing down or losing connection. I had this problem sometimes and problems connecting other times. Try picking up a OBD2 extension and plugging the Tactrix to the extension(leave the extension plugged in). That way, when the connectors wear down, you just replace the $20 extension cable.

Works for me...

Cone_Killer 02-28-2013 09:15 PM

Talked to Mike at Tactrix today. He had me send him all of my SDcard logging data. It looks like its an ECU issue as Strizzy encountered. He said that the data loss appears to be caused by the ECU lowering the priority of the OBD port during those times. Therefore, dropping the connection.

iNVAR 02-28-2013 09:18 PM

That would be weird though because my own problem went away on its own... Unless maybe mine was just caused by a bad connection, hrm.

Cone_Killer 02-28-2013 10:07 PM

I may just check the ecu connections and try again. Could be something a wee bit loose from the factory, who knows.

G5892 03-01-2013 06:09 AM

This used to happen to me a lot. This was the main reason why I switched over to the AP.

Cone_Killer 03-01-2013 07:21 AM

I also had the same problem with my AP which is why I sold it.

Spec B 03-02-2013 06:58 AM

I slightly bent the pins on my tactrix cable to get a better bite on the port. Solved my problem - but they eventually (after a few months) loosen up again - rinse and repeat.

Cone_Killer 03-02-2013 08:24 AM

The OP2.0 is only a week old. I wish the pins were the problem :(

Cone_Killer 03-02-2013 10:10 AM

Spoke with Mike at Tactrix again yesterday. He is having me add in "showsample = 1" in the .cfg file to narrow down repeat data. I have also extended the logging interval by 15 miliseconds to help the communication complete. I'll post up results tonight after I log with the changes.


All times are GMT -6. The time now is 03:36 PM.


LegacyGT.com