Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Smoke when boosting (http://legacygt.com/forums/showthread.php?t=201987)

Fiveostang 02-20-2013 07:30 AM

Smoke when boosting
 
This does not happen all the time only once in a while but when it does decide to do it it pours smoke for a few pulls then stops. It only happens after its been remote started and warmed up

robitrice 02-20-2013 07:47 AM

color of the smoke? Blue, Black, White? Are you tuned? Stock turbo? Any mods? Need some more info

Fiveostang 02-20-2013 08:05 AM

No mods it looks like blue smoke I'm losing oil and but no noises from the turbo it's boosting fine no loss of power and its almost impossible to duplicate on purpose. It doesn't smoke all the time. I posted a while back because of a p0011 code but that was taken care of and I brought it to Subaru to check the turbo and they said it was fine. The car runs with no problems.

Dvour 02-20-2013 11:21 AM

Blue means oil, find the leak and check your oil daily. If its only when the turbo kicks in then id guess it could be an oil feed line to the turbo? Could be wrong though

Fiveostang 02-20-2013 11:35 AM

Quote:

Originally Posted by Dvour (Post 4302649)
Blue means oil, find the leak and check your oil daily. If its only when the turbo kicks in then id guess it could be an oil feed line to the turbo? Could be wrong though

Yea I know blue means oil but its not consistent. It doesn't happen every time I go into boost so if its an oil feed line wouldn't I experience smoke every time I went into boost.

Dvour 02-20-2013 11:39 AM

Possibly, when I got smoke it was cause the valve covers by the camshaft was leaking, it wouldnt smoke when cold but as soon as the car warmed up it smoked when I boosted... just my experience, im by no means an expert

wurkenman 02-20-2013 11:53 AM

My guess would be the oil seal on the hot side. When you give it lots of boost you are feeding more oil and it WILL push past a bad seal. Drive with caution my friend, because when the seal goes you will really use the oil.

Fiveostang 02-20-2013 12:20 PM

Good to know guys. I have a buddy who will check out the turbo but I'm being very cautious and trying to drive in "I" mode to stay out of boost.

Fiveostang 02-20-2013 02:01 PM

Here's what my buddy thinks. He said its probably the turbo seals because its running through way to much oil. About a quart every 150-200 miles.

paintpollz 02-20-2013 02:06 PM

Quote:

Originally Posted by Fiveostang (Post 4302989)
Here's what my buddy thinks. He said its probably the turbo seals because its running through way to much oil. About a quart every 150-200 miles.

Time for a new turbo. Don't roll the dice......

Fiveostang 02-20-2013 02:08 PM

Oh I am on it my dealership is gonna pay for it so he wants to send it for a rebuild.

paintpollz 02-20-2013 02:13 PM

Quote:

Originally Posted by Fiveostang (Post 4303005)
Oh I am on it my dealership is gonna pay for it so he wants to send it for a rebuild.

good work, i guess it's a win win for you then

Fiveostang 02-20-2013 02:20 PM

Yes it is. If they rebuild the turbo it's the same as a new turbo right?

robitrice 02-20-2013 05:44 PM

im going through the same thing and getting it checked tomorrow. Its a good sign though that you caught it now before it got starved and exploded creating a bigger problem.

Fiveostang 02-20-2013 05:49 PM

Yea I've been dealing with it for about a month but everyone who looks at says there's nothing wrong but you don't get clouds of smoke from nothing being wrong and the worst part is I can't duplicate it when I have someone looking at it lol. I hope you get yours figured out.


All times are GMT -6. The time now is 11:38 PM.


LegacyGT.com