Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Detailing, Maintenance, and Long-term care (http://legacygt.com/forums/forumdisplay.php?f=56)
-   -   All my blinkers won't work (http://legacygt.com/forums/showthread.php?t=200932)

rox 02-02-2013 03:58 PM

All my blinkers won't work
 
Not sure where to post this so I posted it in another section as well.

All of my blinkers, front, rear, and mirror blinkers all don't work all of a sudden. All other lights and electronics work and the fuse tested to be fine. I was going to replace it just to be sure. Does anyone have any idea what else it could be?

Really hope I don't have to get into the steering column and check the dang connector.

Any advice/help is greatly appreciated!
Thanks!

ShrinerMonkey 02-04-2013 05:53 PM

Might be a bad relay. In my old Volkswagen the relay for the flashers was located in the hazard switch.

halwith 02-06-2013 03:49 PM

@rox- you should take a moment to fill out your profile with year make model so peoples with knowledge can help. ShrinerMonkey is a sterling example of this for you.

snowdrift86 03-23-2013 11:19 PM

I have the same problem and no one here was helpful...I asked months ago

kirbwrx 04-04-2013 04:42 PM

had a friend with the same problem, turned out to be the relay under the steering column.

KLTMO 04-23-2014 12:32 PM

My blinkers and emergency flasher do not work, 2001 Legacy Wagon, I have replaced the multi switch and flasher. Dealer said it "might" be a module. Any ideas???


All times are GMT -6. The time now is 10:40 AM.


LegacyGT.com