Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Warranty Issues & Problems (http://legacygt.com/forums/forumdisplay.php?f=48)
-   -   windshield washer spray lost it's ummphf (http://legacygt.com/forums/showthread.php?t=200711)

c-lo 01-30-2013 08:30 AM

windshield washer spray lost it's ummphf
 
can't find anyone on here with this issue.

my windshield sprayers are on hitting the bottom of my windshield. there's no more "jet" spray. only way to clean my glass is when I get going fast it sprays the fluid up on the window.

what should I be replacing?

Underdog 01-30-2013 08:32 AM

Either the lines are clogged or your pump is on the way out.

Shotokan1509 01-30-2013 10:16 AM

Are you using washer fluid with de-icer? Could be slushing up in the lines.

c-lo 01-30-2013 01:40 PM

no. just regular fluid and it's 60 deg today no. think it's the pump.

easy to replace?

Claw 01-30-2013 07:37 PM

Odd.. mine are hitting the top half of the windshield, so the bottom half remains dirty.

Giixxer21 02-24-2013 08:56 PM

I regularly clean the nozzles, and blow air threw the lines. If not mine clog with in 5,000 miles

astronerd 03-22-2013 05:37 PM

I have a different problem. On my 1998 Outback (automatic) wagon, when I accelerate... the fluid squirts out of the rear washer sprayer. On my 1998 Outback (manual) wagon, when I accelerate... everything is normal. Is there a check valve somewhere in the line?

orndog 03-22-2013 05:58 PM

Quote:

Originally Posted by c-lo (Post 4269695)
can't find anyone on here with this issue.

my windshield sprayers are on hitting the bottom of my windshield. there's no more "jet" spray. only way to clean my glass is when I get going fast it sprays the fluid up on the window.

what should I be replacing?

Pull the hose apart at each connection point and check for pressure. If you get to the pump and it has low pressure then replace it, it's not that expensive. If the pump has good pressure it can be a bad or clogged line, fitting, or spray nozzle.

Hemingway 03-22-2013 06:21 PM

C-Lo ... I had to change both of my nozzles on my '98 for the same reason. Tried to straighten and clean them periodically for years. The OEM nozzle assemblies are relatively cheap ... ordered them through the eParts site of my local dealership. I think I paid $40 for both.

The assembly comes with the nozzle and a length of tubing ... shorter on the driver side, longer for the passenger side.

They work flawlessly now. Should have replaced them years ago.

KCwagon 03-27-2013 07:11 AM

Quote:

Originally Posted by c-lo (Post 4269695)
can't find anyone on here with this issue.

my windshield sprayers are on hitting the bottom of my windshield. there's no more "jet" spray. only way to clean my glass is when I get going fast it sprays the fluid up on the window.

what should I be replacing?

Rockauto.com has replacement pumps. The factory pump is located at the bottom of the resevoir and is held in place by a rubber grommet (in the hole of the resevoir). It is a pretty easy fix.


All times are GMT -6. The time now is 08:35 PM.


LegacyGT.com