Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Turbo Powertrains (2.0GT, 2.5GT, 2.5XT) (http://legacygt.com/forums/forumdisplay.php?f=12)
-   -   All put back together, with upgrades, new issue. (http://legacygt.com/forums/showthread.php?t=200068)

Cody480 01-20-2013 01:15 PM

All put back together, with upgrades, new issue.
 
So I just got my BNR 16G, Stealth up-pipe, IP&T oil feed, and Cobb AP installed and decided to go for a cruise. I used the preloaded Stg 2 93OCT tune just because it seemed to be the closest match to my upgrades until i get a professional tune. So, i drove it around yesterday and went for a lightly spirited cruise. Everything seemed to be really good over the course of the drive until I was headed home and the vehicle didnt want to boost very high. It goes to about 5psi+- then theres a loud purge sound that seems to come from the intercooler area. The previous turbo did blow and this issue sounds nothing like this. I am really new to the boosted scene still and have very little knowledge of boost, and have no prior knowledge of the boxer. I did take a video to maybe help you help me. I dont have anyone else to help get the sound on video or to help me pinpoint. I have been reading about possible exhaust leaks and vacuum leaks and i have checked to see if any known (to me) lines had busted off but maybe thats not my issue. Any info is appreciated



^^^^VIDEO^^^^

Cody480 01-20-2013 01:16 PM

sorry for the bad BlackBerry video and sound quality

Spec B 01-20-2013 01:38 PM

You should really lay off the spirited driving until you get a tune.

I would start by checking the turbo > IC and IC >thottle body connections.

Cody480 01-20-2013 01:44 PM

Quote:

Originally Posted by Spec B (Post 4254560)
You should really lay off the spirited driving until you get a tune.

I would start by checking the turbo > IC and IC >thottle body connections.

Yes I believe that statement is true all I do is break things. All of those connections are good and tight. It doesn't sound like the turbo is bad again does it? I still need to check the turbo for shaft play and what not but the turbo that blew the first time sounded nothing like this and wouldn't boost at all this one tries but seems like the waste gate is opening or I'm losing pressure somewhere but I have little knowledge of this stuff.

Spec B 01-20-2013 01:46 PM

I cant really tell from the vid..also check your up pipe turbo connection.

Dbl_D718 01-23-2013 04:13 PM

Quote:

Originally Posted by Cody480 (Post 4254517)
It goes to about 5psi+- then theres a loud purge sound that seems to come from the intercooler area.

This is what my car did when the IC>TB hose was leaking. Upon visual inspection it looked fine, but it needed removed/reinstalled/tightened down and then the problem was gone. It's so simple, you might was well do this with all of your IC hoses just to rule them out.

DeltaNu1142 01-23-2013 04:19 PM

What you describes sounds like what DBL & Spec said. I had a massive purge of air on my Stage 2 final tune, which was the turbo-->TMIC hose popping off. The clamp was tight on the hose, the hose appeared to be installed on the turbo flange, but it was not. Check those connections.

Cody480 01-25-2013 06:35 PM

It was the connection from the IC to the TB. The rubber thing that is on the stock hose had a crack in it. I had no idea that something like that would cause a leak but it did!


All times are GMT -6. The time now is 06:03 PM.


LegacyGT.com