Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Traction Control, CEL, and Flashing Cruise (http://legacygt.com/forums/showthread.php?t=199790)

Scooby570 01-15-2013 09:57 PM

Traction Control, CEL, and Flashing Cruise
 
This evening I was driving home from a friends house when out of no where my traction control, CEL, and cruise light (Flashing) all came on at once.
I didn't lose any power or drive-ability and seeing as i was a few miles from home decided not to pull over and shut the car off. when I got home to check the code it was a P0420 (Front 02 sensor) I cleared the code because its actually suppose to snow tonight in North Eastern PA and didn't want an issue with my Traction Control.

Has anyone else had this problem!?!?!? i've read threads that have the cruise and CEL, but no traction control light????? it just seems odd to me. I either have a serious problem or im over thinking it and it just typical for this to happen every time a code is thrown

Oh almost forgot, I have a 09 Legacy 2.5SE with roughly 97K on it.

I'm concerned because, what if this occurred when I was in the middle of driving in a snow storm? could Subaru be this daft and disable the Traction control every time the car decides to throw a code?

Any feed back would be awesome!:icon_bigg

Gex 01-15-2013 10:01 PM

Ohhh how did we ever drive an all wheel drive car in the snow without traction control!

In all seriousness front O2 sensor is pretty easy to swap on the LGT cant imagine it being to difficult on the 2.5i. The LGT sensor is a bosch (or denso) unit and can be had for $150ish? at your local parts store. Also a 22mm box wrench or O2 plug socket.

Scooby570 01-15-2013 10:09 PM

Quote:

Originally Posted by Gex (Post 4248520)
Ohhh how did we ever drive an all wheel drive car in the snow without traction control!

In all seriousness front O2 sensor is pretty easy to swap on the LGT cant imagine it being to difficult on the 2.5i. The LGT sensor is a bosch unit and can be had for $150ish? at your local parts store. Also a 22mm box wrench or O2 plug socket.

Oh I'm no stranger to AWD with no electronic help. My first car was a 98' RS and believe me i had a blast in it, but once i got into the Legacy and felt the car take over when it started to slip, it actually made me feel safer. But in the RS i was always on my toes when driving.

Yeah, i can see the front one from the engine bay. Its going to Subaru for warranty issues: (Broken starter and a malfunctioning Airbag module), I'm going to try and add this to the list so i don't have to fork out the 150 bucks lol!

But does the Traction Control light always come on when there's a code?

Max Capacity 01-16-2013 08:21 AM

Not sure about the traction control light.

But the Dealer will charge more then $150 to replace the front O2. I'm sure the sensor is more then that.

idiot4hire 01-16-2013 08:39 AM

Buy one from advanced auto parts online and use the the promo code trt41 you will get 40 dollars off I just did it

Scooby570 01-16-2013 05:37 PM

I most definitively will be getting a new one.

But I'm still looking for feedback concerning the Trac. Light

Scooby570 01-17-2013 12:38 PM

No one knows????

Max Capacity 01-17-2013 12:54 PM

You may want to pm BAC5.2 or Frank_ster they might know.

m sprank may know too.

Max Capacity 01-18-2013 06:23 AM

I'm going to go out on a limb here and say yes, the three lights will flash when you get a CEL.

Go to an auto parts store and have them check to see if you still have code in there.

mrmegadeth 01-18-2013 02:08 PM

Yes. It says so in the manual if you read between the lines...or at least for my 08 it does. I had the exact same issue.

If you think about it it makes sense. Traction control will take over the engine RPM when it detects a tire spin...the ECU is taking all accessories offline that might "control the engine RPM" except your right foot. It's almost like a limp home mode.

Scooby570 01-22-2013 08:44 AM

Quote:

Originally Posted by mrmegadeth (Post 4252317)
Yes. It says so in the manual if you read between the lines...or at least for my 08 it does. I had the exact same issue.

If you think about it it makes sense. Traction control will take over the engine RPM when it detects a tire spin...the ECU is taking all accessories offline that might "control the engine RPM" except your right foot. It's almost like a limp home mode.

Thats probably it! thanks for the help guys. Its at the dealer today for other parts (Starter, Airbag module) and i menchaned the CEL to the service guy and he said that the code meant that there was something wrong with my Cat or it was an absolutle fluke.

I find that hard to believe that it could be a fluke and I also think its not my cat only because its an 09

awwrxwgn 01-22-2013 11:56 AM

did the mechanic tell you what it was? I was driving today as well as my traction, cel, cruise, and "s" went on. Going to run the codes today after work

BA_SUBARU24 01-23-2013 06:23 PM

I was driving to school today and bam! same thing happened to me... I was just at my subaru dealer last week to get my airbag light and auto start checked out... I have 76k on my 07 LGT. Check engine, cruise and "S" (flashing) lights are on so that means 02 sensor needs to be replaced correct?? Also it will cost me how much for subaru to fix it? Also anyone know how long this will take?
Thanks for the help.
Brian.

ehsnils 01-24-2013 12:55 AM

Read the codes first then we can help you. It could be just about anything at this stage, even a badly tightened gas cap.

Scooby570 01-24-2013 07:34 AM

Exactly what ehsnils said you need a code to determine exactly what the problem is. all those lights come on when you thorw a code reguardless.

My code just happened to be an O2 code.


All times are GMT -6. The time now is 08:59 AM.


LegacyGT.com