Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Smoke from intercooler, coolant smell? (http://legacygt.com/forums/showthread.php?t=199544)

carlson1984 01-12-2013 09:19 AM

Smoke from intercooler, coolant smell?
 
I replaced my turbo a couple of weekend ago and now each time the car is warming up, the car emits smoke out of the Intercooler and I have a pretty heavy smell of coolant in the car. I have been checking the coolant levels in the overflow tank when warm and it does not seem to be going down. Any ideas what this could be and I should check? Thanks

HAMMER DOWN 01-12-2013 10:36 AM

Check coolant hose from turbo to small coolant. Over time the hose balloon & will push coolant pas the spring clamp. I replaced the spring clamps with worm screw clamps for this reason. It a place to start.

Mike

TheBlackPearl 01-12-2013 11:18 AM

Quote:

Originally Posted by HAMMER DOWN (Post 4243110)
Check coolant hose from turbo to small coolant. Over time the hose balloon & will push coolant pas the spring clamp. I replaced the spring clamps with worm screw clamps for this reason. It a place to start.

Mike

Same here.

Oregon OBXT 01-12-2013 03:39 PM

New turbo should have gotten new hoses. They harden over time. Worm clamps can produce more force but they're masking a tired hose. With new hoses, constant tension clamps are preferred IMO as they compensate for hose deterioration over time without the need to retorque.

AkumaMax 01-12-2013 06:16 PM

Quote:

Originally Posted by HAMMER DOWN (Post 4243110)
Check coolant hose from turbo to small coolant. Over time the hose balloon & will push coolant pas the spring clamp. I replaced the spring clamps with worm screw clamps for this reason. It a place to start.

Mike

Yep When I replaced my Turbo I had a problem with the coolant hose on it.

-Samurai- 01-14-2013 10:44 PM

Mine just today came loose (literally sprayed everywhere when I wiggled it). So I repositioned the clamp and made sure it was snug. No steam after that. Hopefully doesn't come loose again. The hose itself seems good still. Not crispy or cracked.


All times are GMT -6. The time now is 08:12 AM.


LegacyGT.com