Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Intercooler Leak (http://legacygt.com/forums/showthread.php?t=197999)

IceCold81 12-12-2012 09:23 PM

Intercooler Leak
 
1 Attachment(s)
Hey all, I've been looking around for some threads on this topic and found SOME info, but it's tough to pin point if directly relative to what I'm seeing?

I've had what looks to be an decent seeping of some sort on my intercooler for some time... Car seems to run fine, boost fine (As far as I know) But being an inter cooler and seeing this level of grunge around the bottom bottom left/passenger corner of the inter cooler, what would some of you make of this? Has anyone else had a similar issue with there stock cooler? I was already planning on replacing in the near future, but I'm curious about the seemingly "OIL LIKE" leak I'm seeing.

My ride is a 2005 LGT with about 100k on it... Compression test done, was within scope/healthy etc. and not overly experienced with the turbo system to know what to expect with something like this? Wouldn't mind to hear some feedback if you'd feel like contributing.

.blackgt. 12-12-2012 11:51 PM

Seems like its your end tank on the stock intercooler.
I think there are a few in the FS section. Replace and have fun.

IceCold81 12-13-2012 12:26 AM

Quote:

Originally Posted by .blackgt. (Post 4201157)
Seems like its your end tank on the stock intercooler.
I think there are a few in the FS section. Replace and have fun.

You think this "Gunk" visible in this pic, is maybe just the air/engine bay grime/moisture combination causing this kind of look?

Max Capacity 12-13-2012 05:02 AM

Clean it the best you can and see how fast it comes back.

IceCold81 12-13-2012 05:33 AM

Quote:

Originally Posted by Max Capacity (Post 4201272)
Clean it the best you can and see how fast it comes back.

I was actually thinking about doing EXACTLY that... Just to see exactly what I'm working with. Good call! ;)

I mean it IS almost a 100k miles and never been touched ha, who knows.

ripemeat 12-13-2012 06:05 AM

it's separating and leaking under boost. Get a new one.

.blackgt. 12-13-2012 07:53 PM

They can be had for cheap, so do your wipe clean and observe test, and then replace accordingly.

My vote goes to a definite leak.

IceCold81 12-13-2012 08:22 PM

Quote:

Originally Posted by ripemeat (Post 4201291)
it's separating and leaking under boost. Get a new one.

So should I be worried that it seems so grimy near the leak? Seeing as it's an air to air leak? Or Is the grime maybe due to the heated/cooling affect of the air to the exterior (Condensation/moisture) and the engine bay grime over time maybe making it look like that?

Quote:

Originally Posted by .blackgt. (Post 4202804)
They can be had for cheap, so do your wipe clean and observe test, and then replace accordingly.

My vote goes to a definite leak.

Yea I'm assuming leak for sure as well, I'm curious to see just how bad it is after cleaning

.blackgt. 12-14-2012 12:21 AM

Looks like some oil residue coming from the leak. This happens (oil in intercooler). I am sure others can chime in as to why this occurs.

IceCold81 12-14-2012 01:55 AM

Quote:

Originally Posted by .blackgt. (Post 4203213)
Looks like some oil residue coming from the leak. This happens (oil in intercooler). I am sure others can chime in as to why this occurs.

Yea I'd like to hear some perspective pertaining to that...

ripemeat 12-14-2012 06:24 AM

the inlet, turbo, and intercooler system circulates small amount of oil (called blow-by). If you have a leak, you'll see the oil seep out. that is the classic spot where the ic separates for these cars.

BarManBean 12-14-2012 06:48 AM

Pm'ed you and whatnot. What folks are telling you here is spot on.

mustangendsley 12-14-2012 08:36 AM

Mine did the same and i just went with the avo one and did not worry about trying to fix the old one. Mine was worse than yours also. Just get a new one original or a avo one.

Mill 12-14-2012 04:16 PM

Checked mine as well and it looks like this too, but on the bottom instead of the top.

Came off the car at about 120k. I didnt notice any leaking issues though when I was stock.

Upon closer inspection it does appear that the tabs have come unbent and the plastic sticks out further compared to the other end. I'm glad I noticed this before I sold it.

IceCold81 12-14-2012 08:21 PM

Is any "Blow-by" or "Leak" mentioned regarding oil in that system, tend to flag major concerns? Or just kind of what our cars do?


All times are GMT -6. The time now is 06:43 PM.


LegacyGT.com