Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Older Legacy Performance (http://legacygt.com/forums/forumdisplay.php?f=28)
-   -   Rough Idle After fueling (http://legacygt.com/forums/showthread.php?t=196331)

Myanono 11-13-2012 05:50 PM

Rough Idle After fueling
 
2003 Legacy runs rough after filling up with gas. I know I'm not supposed to top off, but still runs rough for a minute or so then clears and runs fine. Other that that the car runs great. Any ideas on what I need to do to fix this?

Stang70Fastback 11-13-2012 05:57 PM

I see you found the right forum section (kind of)...
...at least a bit more right than the "general chat" section, lol. I'll paste my answer here too:

I've heard that this can be caused by "rounding up" when filling up after the gas dispenser has clicked off (referring to rounding up to the nearest dollar, though in my case it's usually just I-WANT-ALL-THE-FUEL!!!). This can force gas into the evap system of the car, and cause exactly what you are referring to.
Basically your car has an extra system that stores excess fuel vapor that builds up in your tank as the gas heats and cools. When you start your car, that excess vapor is pulled into the intake and burned off in the engine. If you force liquid into that system, then rather than pulling a bit of fuel vapor down the air intake, it pulls in raw, liquid fuel, resulting in an overly rich fuel mixture, which can cause the car to stumble at first...
...does that sound like it might be what you are experiencing?

ufa turtle 11-19-2012 01:53 AM

Check your purge solenoid. Could be stuck open.


All times are GMT -6. The time now is 03:43 AM.


LegacyGT.com