Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fifth Generation Legacy (2010 - 2014 ) (http://legacygt.com/forums/forumdisplay.php?f=92)
-   -   Nav-Stereo issues (http://legacygt.com/forums/showthread.php?t=196285)

Scooby Fan 11-12-2012 11:46 PM

Nav-Stereo issues
 
Just picked up my new '12 Legacy Limited a few days ago..Equipped with the Pioneer GPS/Sreo combo system..love the car but having some issues with the Nav/stereo. Today I called Sirius to activate my 3 month free trial of the Satellite Sirius radio system ,.....Sirius tells me that it is all activated but no sound from any of the channels....the interface seems to be working and the Sirius tech guy says it shows as working at their end....BUT no sound at all...at any volume. They claim to have had numerous problems with this in new Subarus ......anyone else experience this problem??
Obviously it is going back to the dealer to be checked.

BTW that GPS in the Pioneer system is the WORST I have ever seen....today I was driving along Lougheed Hwy in Burnaby BC and it showed me on Keale Street in Ontario ....the day I picked the car up at the dealer in Vancouver...it showed me that I was in Los Angeles..... I don't really care about the GPS that much because I will just put my Garmin back in anyway....but that stereo is a nightmare....232 page op manual just for the stereo....and no one at the dealership can explain all the functions.:confused:

Magic Marker 11-13-2012 09:37 PM

I would say the nav has a pretty big learning curve. It's not entirely user friendly, but once you get to know it, it functions well.

Although I can't chime in why your Sat radio isn't working.

BTW, forget about using the voice recognition... it's terrible. Oh and you can't even enter destinations via voice. Do the Nav hack. You'll thank us later.

Congrats!

Ellesedil 11-13-2012 09:45 PM

I had all of my radio's output stop working on me once (I have the Harman Kardon found in all the other 5th gen GT's). FM, AM, USB, XM, didn't matter what the source was. I was in traffic anyway and instead of coasting, I sped up to the car in front of me so I could stop and restart my car. Radio worked fine afterwards.

Having said that, there are other minor quirks, particularly with the USB playback, such as the radio getting stuck on the current track, even when the track should have ended.

I wonder if the 2013 system is in better shape.

Scooby Fan 11-13-2012 11:11 PM

Off to the dealership first thing in the morning....I'll post the results. I spent most of my free time today playing with the Nav functions......truly weird how inaccurate it is...can't find where it is a lot of the time and picks the most bizarre routes.......at one point today I was about 6 Km from home and driving along a straight highway that goes right to our house....the GPS wanted to take me on a route that wandered all over the city.
I am very familiar with Garmin technology....anyone know if there is a way to set "Shortest" or "Fastest" route on these Pioneer Navs.....I search everywhere and can't find that.

Thanks

Magic Marker 11-14-2012 08:57 PM

^^It sounds like your nav routing preferences are off...

Scooby Fan 11-14-2012 10:30 PM

I had it checked out at the dealership today...the whole thing is F**ked...they took it apart and tried a variety of different "Known to be good" modules and it just does not work properly......Sirius radio does not work at all......stereo drops dead from time to time while driving and the GPS couldn't find it's own ass with both hands.
Todays GPS blunders...sitting at and intersection waiting to turn right towards home...and the GPS is set to take me "Home"......instruction is to drive straight ahead for 700 meters, make a U turn, drive 700 meters back to the intersection I am sitting at and then turn left...WFT????
Entire Navi unit is being replaced as soon as they get a new one in...they say about a week. The service guy took it for a drive and came back shaking his head.....just a bad unit it seems.....they confirm that all the settings are correct but the unit can't follow them and the stereo is basically toast.

BTW....I set the GPS, when I took delivery, saving the dealership lot as a "Favorite"....it cannot get me to within 5 Km of the dealership on it's own ;)....just keeps sending me around in circles if I didn't know to ignore the directions.

sschmelcke 11-15-2012 06:33 AM

mine has been flawless since I got the car almost 3 years ago. That being said it sounds like you need a warranty replacement. hopefully its still under warranty. otherwise id go aftermarket although my wifes kenwood has more bugs then our stock one.

Ellesedil 11-15-2012 07:12 AM

Are they replacing it with another 2012 nav unit or one from the 2013 model year?

Scooby Fan 11-15-2012 09:26 AM

Quote:

Originally Posted by sschmelcke (Post 4159694)
mine has been flawless since I got the car almost 3 years ago. That being said it sounds like you need a warranty replacement. hopefully its still under warranty. otherwise id go aftermarket although my wifes kenwood has more bugs then our stock one.

Pretty sure it is still on warranty...the car is 8 days old :lol::lol:
They are putting a new one in next week.....I have a few Garmins laying around in case the new one is no better.

Scooby Fan 11-15-2012 09:32 AM

Quote:

Originally Posted by Ellesedil (Post 4159731)
Are they replacing it with another 2012 nav unit or one from the 2013 model year?

No way to know....I asked about that and they say it is the same unit for 2012 and 2013....they also "Candidly" admit that they have been swamped with complaints about these Nav units since they first started using them .....apparently only the Canadian models get the Pioneer unit and the US models get Kenwood Nav systems.....Any of you with US models have the Pioneer in your cars???

According the the sales staff at the dealer....the guy at Subaru Canada who did the deal with Pioneer for all these units to be used has been FIRED!! Who knows if that is true or maybe just a way to sooth irate customers??

Scooby Fan 11-15-2012 02:26 PM

Did a little experimenting today....seems that a big part of the GPS problem is the lack of accuracy......it cannot detect it's position any better than about 2 or 3 city blocks..... I live about 3 blocks south of a major divided roadway.(Hwy) and my driveway is parallel to the Hwy.....when I am in the driveway the GPS says I am on the Hwy.................hopefully the new one is better;)

killerniceguy 11-15-2012 07:51 PM

I have a 2012 LGT in Canada and it has the POS kenwood nav unit. They only came this way up here, every option or buy something else. Had I known it was going to be this bad....

Scooby Fan 11-22-2012 10:44 PM

Here is the end of this little saga......On the second visit to the dealership they told me they were NOT going to replace the whole unit. They had checked with Pioneer who say there have been loads of problems like mine and it is all Subaru's fault.
The Audio/Nav tech did a check on mine and sure enough ....It had been installed incorrectly and the wiring was botched by the installer....he re-wired it correctly and all is well........That is to say "As good as that POS GPS can be" stereo is awesome and the Sat radio works fine....GPS is better than before but a very distant comparison to a Garmin (Bought a new Garmin Nuvi at Costco because I just wouldn't trust the Pioneer on a long trip or in strange cities)


All times are GMT -6. The time now is 12:28 AM.


LegacyGT.com