Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Second Generation Legacy (1994 - 1998) (http://legacygt.com/forums/forumdisplay.php?f=95)
-   -   Cel. (http://legacygt.com/forums/showthread.php?t=196214)

DOHCEJ22E1 11-11-2012 08:17 PM

Cel.
 
I'm thinking the IACV is messed up in some way.
How do I know? I don't since I don't have my scanner today.

However, when the car is in park, the idle jumps between 1500rpm to 2500rpm constantly like the way bad IACV on Hondas do & when I am driving it, it stays at exactly 1500 rpm without my foot on the pedal.

I have to actually force the car to stop by braking a little harder than usual.

Any suggestions on this?

Kennyfvholla 11-11-2012 08:24 PM

I'm guessing the RPM hovers at a little higher than idle when the car is stopped and in gear?

Look at the throttle body when the motor is running and car is stopped. It should look like a bit of throttle is being applied.

Did anything happen before this issue? What codes are popping up? There could be another issues that's causing the IAC to "giving it a bit of gas" or it could be a throttle body issue or it could some other issue.

What does the throttle body look like when the motor is shut off compared to when its running? What happens as soon as you start the car?

DOHCEJ22E1 11-11-2012 08:58 PM

Quote:

Originally Posted by Kennyfvholla (Post 4154591)
I'm guessing the RPM hovers at a little higher than idle when the car is stopped and in gear?

Look at the throttle body when the motor is running and car is stopped. It should look like a bit of throttle is being applied.

Did anything happen before this issue? What codes are popping up? There could be another issues that's causing the IAC to "giving it a bit of gas" or it could be a throttle body issue or it could some other issue.

What does the throttle body look like when the motor is shut off compared to when its running? What happens as soon as you start the car?

As soon as I start the car, the rpms shoot straight up to 2500 rpm & then back down to 1500, then begins & back & forth bounce between those rpm points.

There was a pinging event but I stopped that by re-adjusting the knock sensor & replacing the vacuum lines to the intake & fuel regulator about 3 days ago.

I borrowed my neighbor's scanner since mine is 4 towns away & since the scanner I used was simple, it only gave my a code w/no explanation. PO1507.

I've looked online & I've found that this can be one or many issues. I'm going to tackle this as soon as I can because if at all possible, I'd like to prevent damage.

Kennyfvholla 11-11-2012 09:07 PM

What does the throttle look like with the motor on compared to off?

Chek and clean the IAC

Check the TPS

Check the intake for any sort of vacuum leaks

DOHCEJ22E1 11-11-2012 10:04 PM

I will check everything out tomorrow & come back to this.

Stang70Fastback 11-11-2012 10:46 PM

IAC does sound like the culprit. However it could even be something as silly as a bad coolant temperature sensor.

broknindarkagain 11-11-2012 11:39 PM

Go to Autozone and get the codes scanned for free

DOHCEJ22E1 11-12-2012 01:02 PM

Got my scanner back & plugged it in. PO1507 with Idle Air Malfunction, & about 6 different descriptions detailing the Idle Air Control Valve issue. I took apart the whole assembly & it is caked full of what I believe is sludge. I'm cleaning out everything & repositioning all of the wiring. Hopefully, that should bring it back to normal.

DOHCEJ22E1 11-12-2012 02:17 PM

Cleaned the IACV & re-adjusted the TPS. Now it runs normal. Thanks for the suggestions! They worked well :D


All times are GMT -6. The time now is 08:58 PM.


LegacyGT.com