Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fifth Generation Legacy (2010 - ) (http://legacygt.com/forums/forumdisplay.php?f=92)
-   -   anyones cars feels like its gonna stall out (http://legacygt.com/forums/showthread.php?t=194727)

abody 10-14-2012 02:20 PM

anyones cars feels like its gonna stall out
 
Everyone once in a while, my rpm's will drop a little when I stop, at idle, go below idle, then come back up, its not constant so I can't get it checked out yet. Figure it has to more consistant. Anyone else have this or just a subie quirk?

20SWP10 10-14-2012 02:44 PM

Mine and quite number of others have that prob. I couldnt "duplicate" the problem, so they couldnt do anything. Some mechanic over at the dealership said it was something about "programming" issue thats cant be fix yet...there's few threads about this

Regis1756 10-14-2012 03:22 PM

It's a normal thing.

wrxwhit 10-14-2012 03:28 PM

Could be caused by the bypass valve not shutting quick enough under vacuum causing rpms to jump when you change out of gears to neutral when driving.

PoManzAWD 10-14-2012 07:21 PM

Quote:

Originally Posted by wrxwhit (Post 4114293)
Could be caused by the bypass valve not shutting quick enough under vacuum causing rpms to jump when you change out of gears to neutral when driving.


There is no idle air control system on electronic throttle controlled engines.

E-throttles move the throttle plate themselves to maintain idle speed.

FWIW, there's about 3 recent threads on this idle stumble deal for 2010+ 2.5i CVTs. It's a programming deficiency that I'm sure SOA will drag their feet on fixing for everyone.

Joel

wrxwhit 10-14-2012 07:25 PM

Quote:

Originally Posted by PoManzAWD (Post 4114488)
There is no idle air control system on electronic throttle controlled engines.

E-throttles move the throttle plate themselves to maintain idle speed.

FWIW, there's about 3 recent threads on this idle stumble deal for 2010+ 2.5i CVTs. Programming deficiency.

Joel

My statement has nothing to do with the iac system, but the bypass valve. Bypass valve rpm bounce. This same thing occurred in my wrx and was able to fix with a blow off valve which closed much quicker than the oem bypass valve.

EMVirostek 10-14-2012 10:00 PM

It's not just the CVTs. My 6MT does the same thing. Been in contact with SOA and they say its normal operating conditions. I got an extended warranty out of them. That's all. I don't see a fix in the near future.

acumenhokie 10-15-2012 06:21 AM

I get a major bounce every now and again with the LWFW. It's normal.

dgoodhue 10-15-2012 06:28 AM

Quote:

Originally Posted by EMVirostek (Post 4114665)
It's not just the CVTs. My 6MT does the same thing. Been in contact with SOA and they say its normal operating conditions. I got an extended warranty out of them. That's all. I don't see a fix in the near future.

Yeah my 6MT does the same thing. The RPM don't drop much if it all but it sounds like its going to stall.

PoManzAWD 10-15-2012 08:22 AM

Quote:

Originally Posted by wrxwhit (Post 4114494)
My statement has nothing to do with the iac system, but the bypass valve. Bypass valve rpm bounce. This same thing occurred in my wrx and was able to fix with a blow off valve which closed much quicker than the oem bypass valve.

This thread is in regards to a 2010-2012 non-turbo EJ 2.5.

mark5032 10-15-2012 08:29 AM

This happens to my car every once in awhile. It has never actually stalled so I don't worry about it.

wrxwhit 10-15-2012 09:09 AM

Quote:

Originally Posted by PoManzAWD (Post 4114911)
This thread is in regards to a 2010-2012 non-turbo EJ 2.5.

Ah just noticed no scoop on OP avatar:)

PoManzAWD 10-15-2012 09:26 AM

Quote:

Originally Posted by wrxwhit (Post 4114986)
Ah just noticed no scoop on OP avatar:)

No sweat.

I always thought it was just the hamster stumbling a bit on the wheel causing the idle blip anyway! :spin:

Joel

abody 10-15-2012 10:02 AM

Thanks for all your responses , I won't worry about it.

BADLEGACY11 10-22-2012 05:01 PM

If yours is a CVT there is a ECM update that I had done on mine recently at the dealer and it made a world of difference in the operation of the CVT. Similar issues as yours. I think there is a TSB for it.


All times are GMT -6. The time now is 01:57 PM.


LegacyGT.com