Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Rebuilt engine installed..but now misfiring? (http://legacygt.com/forums/showthread.php?t=194270)

leggyman17 10-06-2012 01:13 PM

Rebuilt engine installed..but now misfiring?
 
Just got my engine totally rebuilt. Installed it last night and i have a constant misfire in cylinders 1 and 3 (right side bank) Checked coils, not the problem. Spark plugs are new ( NGK iriduim 1 step colder) gapped to .030. coils are getting spark and injectors are getting signals (checked with noid light)

Is it normal for a rebuilt engine to misfire ?

only ran it for about 20 minutes..

help!

Max Capacity 10-06-2012 01:23 PM

No it's not normal.

Can you swap plugs and see if the misfire moves.

I can't remember what I gaped my plugs at. But I don't think it was that small.

leggyman17 10-06-2012 01:26 PM

didnt swap the plugs...their new so its not like their fouled out or anything

ehsnils 10-06-2012 01:28 PM

It's not normal, and the first thing I would check is that the cam timing is correct since that's a common part for those cylinders.

And do a compression test to verify that nothing is wrong.

Other causes may be the manifold gaskets on that side and fuel feed. Also check that the TGV:s works as they should (if you have them).

leggyman17 10-06-2012 01:29 PM

timing looks ok (all the marks line up accordingly

wouldnt i have a TGV fault if they werent working?

Max Capacity 10-06-2012 01:31 PM

I think he's saying you may have a leak in one of the gaskets or seals.

But that would present its self as a vacuum leak, right ?

leggyman17 10-06-2012 01:35 PM

i dont think theirs a vacuum leak... while its running i sprayed brake cleaner over all the joints (intake manifold, TGV's TBhose, vacuum lines ,etc) and no noticable difference in RPM

leggyman17 10-06-2012 01:37 PM

also im on my EFI logics map tune wise...should i go back to the stock map or does that make a difference?

Max Capacity 10-06-2012 01:46 PM

It has to be something simple.

Make sure all connectors are installed tightly.

Step back, deep breath, get a bite to eat, look everything over.

leggyman17 10-06-2012 01:48 PM

thats what i keep saying lol

i left the car. il do something about it tomarrow just trying to go over everything in my head.

idk what it could be

Max Capacity 10-06-2012 01:49 PM

headed out for the evening my self.

Good Luck


All times are GMT -6. The time now is 02:52 AM.


LegacyGT.com