Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   pffe codes and misfire codes (http://legacygt.com/forums/showthread.php?t=194107)

stevo0525GT 10-03-2012 02:17 PM

pffe codes and misfire codes
 
Hey. I have an 05 Subaru legacy 2.5 gt.mods include fp black Turbo. Fmic. Borla headers with perrin up pipe and down pipe. 850 CC dw injectors. Grimspeed air fuel seperator and light weight crankshaft pulley. Recently installed a brembo brakes and Cobb SF intake tial q bov and Cobb ap. After I.changed the bov out the other day there appears to be a vacuum leak everytime I slow down the rpms drop down to like 200 sometimes just dies. And sometimes if I let it sit and idle it goes.crazy too. Any ideas on.what could be causing the misfire codes or p1491 code or p0030 codes?

stevo0525GT 10-03-2012 03:08 PM

I do have misfire codes for every single cylinder as well as the pffe and I.have looked at every forum and couldn't find a solution?

Max Capacity 10-03-2012 03:46 PM

have you done a boost leak test ?

This may help.
http://www.subaruoutback.org/forums/...ewed-wire.html

This is a list of codes in the warranty forum on here.

the p0030 sounds like a bad front O2 they are about $100. call a lot of auto parts stores, the prices very widely.

stevo0525GT 10-03-2012 04:07 PM

Yes I have done a boost leak test and nothing to be seen yet. At least on the old bov I saw some forums and it seems alot of people said its a coil pack problem or fuel injector problem.

Max Capacity 10-03-2012 05:34 PM

You can move the coil packs around and see if the code follows the coil pack. That' if you get a code for say, missfire in #2. Move it to #4 and see if the code follows it.

How many miles on the car ?

How long has it been on tune ?

stevo0525GT 10-03-2012 08:39 PM

Its a code for all 4 cylinders tho. And I haven't dyno tuned my car yet since the new Turbo yet I have 75000 miles on the car.

stevo0525GT 10-03-2012 08:43 PM

Actually every one but cylinder 3

stevo0525GT 10-04-2012 06:22 PM

It is also running very rich

Max Capacity 10-05-2012 06:31 AM

Where do you live ? Get the car to a Tuner and have them street tune the car and see what they can tell from the data logs.

Or can you data log and send info to a Tuner ?

ehsnils 10-05-2012 12:55 PM

Quote:

Originally Posted by stevo0525GT (Post 4099206)
Actually every one but cylinder 3

If all except #3 I would start to look at the injector for #3 - it may be the real culprit. If that injector gives a lot more fuel than the others then the car will lean out the other cylinders causing them to misfire since the O2 sensor won't know that one cylinder is rich and the others are lean.

If you look at the spark plugs - are they identical or is one of them having a different look?

stevo0525GT 10-06-2012 02:18 PM

I reset the Ecu and it popped up.with p301this time so no cylinder 4 and 2. And the pffe code again. Also I was looking at the charged pipes right by the bov coming from the intake manifold and it was oily right after I drove. could a boost leak cause the car to idle eradicallyand die when I slow down? And cause the cylinder misfire code to pop up?

stevo0525GT 10-06-2012 02:21 PM

B/c I feel like when I swapped my bov out is when it started idling funny

stevo0525GT 10-07-2012 12:48 PM

Could that be because of a boost leak?

ehsnils 10-07-2012 11:11 PM

If the new BOV isn't sealing correctly it certainly can cause trouble. Or if you forget to connect a hose.

stevo0525GT 10-07-2012 11:11 PM

It is sealing properly an connected the hoses


All times are GMT -6. The time now is 09:25 AM.


LegacyGT.com