Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   How Much Play In Your Gas Cap? (http://legacygt.com/forums/showthread.php?t=194064)

chemicalbreeze 10-02-2012 06:13 PM

How Much Play In Your Gas Cap?
 
My Check Engine light came on and the Cruise Control began flashing after I went over an off camber highway bridge expansion joint at speed. I was leaving Toronto, heading west via the Gardener, anyone that drives that stretch knows the area I'm talking about. With the help of this very site and specifically this forum, I checked the gas cap and sure enough, I didn't tighten it all the way and that bump must have dislodged it. I threaded it correctly and clicked it a couple times. After a couple hundred kilometers, both lights went off, only to come back on the same day. I needed to gas up today and noticed that when the cap is threaded correctly there is still some play. I can wiggle the cap after it has been tighten past clicking. Could that be the source of the Check Engine and flashing Cruise or is it normal? Next time you are gassing up can you see if your cap can be wiggled after it has been tightened? I drive a 2006 Legacy GT wagon, with a manual transmission. I don't want to bring it in if the light will go off on its own, which it did... briefly.

Thanks in advance, to all those that will help.

InnocentGuns 10-02-2012 06:57 PM

Get codes scanned to see what it actually is.

scoobyscoodle 10-02-2012 10:52 PM

Please don't tell me you got any soap in there.

Max Capacity 10-03-2012 03:34 AM

I think there is no play.

cypher0117 10-03-2012 10:04 AM

I've actually idled my car for several minutes without the gas cap even screwed in and didn't get any codes. Take it to any auto parts store and they should be able to pull the codes for you. But when fully tightened (a few clicks) I don't get any wiggle.

Max Capacity 10-03-2012 03:37 PM

Checked mine today, the cap wiggles after filling the tank.

The threads feel tight and the seal feels tight, but the plastic cap has play.

dr_sharp 10-03-2012 03:51 PM

Flashing cruise is typically something serious. I don't think the gas cap issue would cause that.

Max Capacity 10-03-2012 05:35 PM

No Flashing CEL is serious, not flashing cruise.

babybluelgt 10-03-2012 06:09 PM

The only time I've had a flashing cruise light was after playing in some snow and it was for an ABS sensor because snow got all jammed up everywhere. Once the snow melted I cleared the code and it never came back. So moral of the story is make sure you didn't knock anything lose. But I would get the codes read anyway.

HDTurbo 10-03-2012 06:21 PM

my cruise started flashing after i got a wheel off the ground on a hilly corner. just had to cycle the ignition and it returned to normal.

But - my gas cap leash just broke...wonder how much for a new one...

chemicalbreeze 10-04-2012 06:28 PM

Thanks a lot Max, just wanted to make sure, because I had not noticed that before.

Needless to say, the codes went away today on my way home from work. Fingers crossed that they stay dark.

-Samurai- 10-04-2012 09:49 PM

Its the gas cap. Mine did this before, filled up and about 4 starts and 50 miles of driving the engine light came on and cruise was flashing. Did'nt know what it was at the time called the dealer they said make sure the gas cap is tight. Reset the light. Never came back on. Then filled up about a week ago too and the light did the same thing. This time DID NOT reset the light after I tightened the cap. Shut off by itself.

Max Capacity 10-05-2012 04:57 AM

Your welcome, You need to make sure the cap clicks at least 3-4 times when you put it on.


All times are GMT -6. The time now is 09:51 AM.


LegacyGT.com