Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Mountain West (http://legacygt.com/forums/forumdisplay.php?f=47)
-   -   CO: 05 LGT power loss, help! (http://legacygt.com/forums/showthread.php?t=192830)

Luv_a_Legacy 09-11-2012 10:15 AM

CO: 05 LGT power loss, help!
 
Any CO. 05 LGT owners able to help? Take a look at it? I need info on where to go, shops that can help and give me info? I'm in Commerce City, and willing to travel to get my car back to safe running. Its got a few mods so if anyone is able to help, just let me know! :redface:

cryo 09-11-2012 03:01 PM

Details as to what its doing and what mods are currently on it?

Dave

KBGRIZZLY64 09-11-2012 04:40 PM

Quote:

Originally Posted by cryo (Post 4066251)

Dave

Ya talk to Dave he is very helpful and local I highly recommend him.

ragman 09-12-2012 08:22 AM

You could try to reset the ECU. (easiest non-technical way is to unhook the battery for 5 minutes). And see if it drives like normal afterward. Then, if it continues to go into safe mode, then you will need to investigate.

Brady 09-12-2012 10:24 AM

WARNING: This post contains Smart-Ass comments and should not be taken seriously

Did you recently move from somewhere with a lower elevation?

Brady 09-12-2012 11:11 AM

On a serious note, I now believe that this was Legend's car.

Scratch that. Not the same.

Luv_a_Legacy 09-12-2012 07:19 PM

Yeah Arizona actually. And it may have been another forum members car. Lol, I just need to know what to do!
It has;
K&N cold air
FMIC
Coilovers
2010 wrx intake manifold
And other minor things like HIDs and sound system.

Brady 09-13-2012 09:32 AM

Well, as mentioned in your other thread, go pull the codes and find out what those tell you.

If you don't think you can get those on your own, you should probably have the car towed to a place like Super Rupair, or SUBA Performance.

Luv_a_Legacy 09-13-2012 04:49 PM

I've actually heard bad reviews from suba, is it wise to go there? Is there anything else?

Lgt07 09-13-2012 09:26 PM

If Dave (Cryo) can't help you out, I recommend Metro Performance, talk to Ben.

cryo 09-13-2012 09:42 PM

I'm still curious to what its actually doing?.....is it running rough, blowing smoke, not boosting, throwing codes?....did it run fine in arizona then you came here and are having issues?

btw suba does great work....so does metro...all awsome guys.

Dave

Luv_a_Legacy 09-13-2012 11:22 PM

Well a few days ago, it started to feel like it had no power. Especially up a hill. When I'm at a stop light, it's a little shaky, but it's been that way for awhile and when I take off, my car just falls flat on its face until about 26-2800 rpm when my car boosts, then itll go. And that same day a puff of smoke came through my vents. After that I pulled over and had it towed. I haven't driven it since. It pulled a few codes before and one was too much boost, which I knew, I just haven't gotten a new boost controller. I just want to know what to do, and where would b a great shop to bring it where they won't bullshit me and take my money.

cryo 09-14-2012 06:45 AM

Well its hard to say based on that but the only thing that sounds %100 mechanical is the puff of smoke through the vents. Your stock electronic boost controller is probably still fine so i wouldnt replace that just yet. Its very possible a few of your other issues are related to the mods and the tune designed for a lower altitude.

I wouldnt want you to drive the car if there is a mechanical issue and im not real close to commerce city.

Pm me and maybe we can work something out.

Dave

Luv_a_Legacy 09-14-2012 10:41 AM

Pm'd


All times are GMT -6. The time now is 03:17 AM.


LegacyGT.com