Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Turbo Powertrains (2.0GT, 2.5GT, 2.5XT) (http://legacygt.com/forums/forumdisplay.php?f=12)
-   -   cooling fan running over time (http://legacygt.com/forums/showthread.php?t=18618)

mattg 09-10-2005 08:51 PM

cooling fan running over time
 
the last couple days i have noticed my radiator cooling fan has been running much more often than in the past few months i've had my car. in fact today when i left work it ran from the time i started the car until i got home.

the only thing that has changed is the temperature, which has dropped into the 50's.

my temp guage is still in the normal operating range.

i'm running a PDE catless up and AP stage 1 w/ PDX maps.

TIA for any info.

mwiener2 09-10-2005 09:02 PM

have you had the windows up and the Climate control on more than usual?

laz 09-10-2005 09:27 PM

I believe there is a thread here somewhere where people are complaining from the same thing and it is an ECU problem. I am too lazy to search, but search and you'll find it.

X

mwiener2 09-10-2005 09:43 PM

no, i think this is just normal and he's not used to it yet.

mattg 09-10-2005 09:49 PM

Quote:

Originally Posted by mwiener2
have you had the windows up and the Climate control on more than usual?

nope. this was w/ the climate control off.

i took another hour long drive after my drive home from work and the fan didn't stay on constant like it had earlier. it cycled more like you would expect it to.

mattg 09-10-2005 09:50 PM

Quote:

Originally Posted by mwiener2
no, i think this is just normal and he's not used to it yet.

it just doesn't make sense to me that the fan would be on more often in colder weather. :confused:

RobY 09-10-2005 09:56 PM

Quote:

Originally Posted by mwiener2
no, i think this is just normal and he's not used to it yet.


Definatley not normal, Dealer replaced my ECU with a revision B unit.

EDIT: however I beleive your problem is a little bit diffrent. My fan would stay on ALL THE TIME and it wouldent turn off EVER.

mattg 09-10-2005 10:04 PM

Quote:

Originally Posted by laz
I believe there is a thread here somewhere where people are complaining from the same thing and it is an ECU problem. I am too lazy to search, but search and you'll find it.

X

found it http://www.legacygt.com/forums/showt...ht=fan+cycling


All times are GMT -6. The time now is 03:04 AM.


LegacyGT.com