Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   What's your most embarrassing Legacy DIY mistake? (http://legacygt.com/forums/showthread.php?t=177708)

radioflyer2006 01-11-2012 08:04 PM

What's your most embarrassing Legacy DIY mistake?
 
I'm sure we have all made mistakes, but hey, we all learn from them, right?

Up until last year, I had never changed the oil in anything besides a go-kart.

In the photo below I was changing the oil... tell me what is wrong with what I had actually "changed". (I've since learned from this mistake and I don't even get a drop of oil on the ground.)

http://i20.photobucket.com/albums/b2...u/IMG_0179.jpg
Hint: Where is that drain pan located?

LosAngelesLGT 01-11-2012 08:19 PM

Id be way more interested to see a photo of the look on your face when you popped the oil filter off :lol:

el5y 01-11-2012 09:50 PM

Not on my lgt but on my old 240 I changed the oil but didn't tighten down the new filter completely. Talk about bathing in expensive mobil 1 oil...

TRSCobra 01-11-2012 09:56 PM

^^^ I did that on my old jeep cherokee several years ago, only I forgot to put the drain plug back and I lost 6 quarts of castrol syntec. What a mess!

On my LGT, I messed up the chrome rings around the projectors when I blacked the headlights out. I ended up painting over everything in black.

2.5GT_dude 01-11-2012 09:59 PM

Installed new brakes and rotors on the Legacy one night....forgot to install the rear pads. I don't know how or why, exhaustion?

FiberglassCustoms 01-11-2012 10:07 PM

Over tightening the ACVS Banjo Bolt & snapping it off after waiting 2+ Months to get My Vehicle Running Again-Thank You Mike @ Infamous!

Running Non Synthetic-Sure came out like Water

Buying the Legacy that I did-Auto

Not doing More Research on the "Turbo Issue."

DRoc7822 01-11-2012 10:51 PM

When I went to install the exhaust...I had tried to put the midpipe on every single way except the right way. Didnt realize it till the next day. Either that... or I ordered an Afta Maf from Mike... and somehow AVO sent me the Throttle hose instead. I spent the next 1/2 hours trying to fit the throttle hose onto either the intake or the inlet. Only to come and realize it was the wrong part.

jcraw84 01-11-2012 11:39 PM

When I pulled my downpipe out I was having trouble pulling it out from underneath. I pulled on it for about 30 mins before it finally came out. Only to have broke a seal and push the "half moon" seal (don't know the real name) that is near the heads into the engine causing an oil bath. :redface:

Drift Motion 01-12-2012 12:20 AM

forgot to plug in the MAF after installing the intake

not completely heated up the headlight before trying to crack it open

radioflyer2006 01-12-2012 05:29 AM

Quote:

Originally Posted by LosAngelesLGT (Post 3701744)
Id be way more interested to see a photo of the look on your face when you popped the oil filter off :lol:

If you think that would have been good, then you would have loved to see my face when I suddenly realized that I hadn't emptied my oil at all. What I had done was empty out the entirety of my transmission fluid...

Grrupt 01-12-2012 05:34 AM

Quote:

Originally Posted by Drift Motion (Post 3701975)
forgot to plug in the MAF after installing the intake

not completely heated up the headlight before trying to crack it open

Lol I just did that last week. Forgot to plug back in my MAF.

chutrain 01-12-2012 06:13 AM

On another car, but was working on the rear brakes and trying to get the rotor off, but it wouldn't budge at. Turns out I left the hand brake up.

soloz2 01-12-2012 06:24 AM

I purchased a used starter here as mine was giving the dreaded squeal on cold mornings as it wasn't releasing from the flywheel as it should. I took the starter apart, cleaned and greased it up then installed. Car started up and I drove home. (was at a friends as I don't have a garage)

I didn't go anywhere the next day, but at about 8:30pm I went into my office and stepped on something... It was the spring that goes on the plunger... Was a simple fix, but I fixed it out in the cold in the dark. Thankfully, I replaced the two philips screws with bolts so I could remove the selinoid without removing the starter!

CL21376 01-12-2012 06:28 AM

Replacing the water pump on my f-body and I failed to drain the coolant. Got a nice antifreeze shower when I disconnected the coolant line.

ShadowImg 01-12-2012 06:33 AM

Mine was the first time I tried to change oil using a lift. I failed to realize that when you are laying down and removing an oil filter your arm is at a very different angle. When standing up, you get a nasty lesson in fluid dynamics when you pop the filter off.


All times are GMT -6. The time now is 01:15 AM.


LegacyGT.com