Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Warranty Issues & Problems (http://legacygt.com/forums/forumdisplay.php?f=48)
-   -   2012 Legacy 2.5GT - Hearing Strange Engine Noise (http://legacygt.com/forums/showthread.php?t=174287)

nuclrxn 11-14-2011 11:01 AM

2012 Legacy 2.5GT - Hearing Strange Engine Noise
 
Not sure what this noise is, but maybe the experts do. When the car is warmed up, if I accelerate past 2500 RPMs, in any gear, I hear a horn-like noise from the engine. Check it out.


Thoughts? :confused: My car only has 2700 miles on it.

SurlyOldManMN 11-14-2011 12:23 PM

Could well be loose IC -> TB hose and/or folded gaskets. Pull the intercooler. I got the "balloon whine/honk" when the gaskets started to fold over and also to a lesser extent when the hose was wiggling loose.

01rs25 11-14-2011 12:29 PM

I would happen to agree. Sounds like a loose charge pipe somewheres.

With only 2700 miles I would take it back to the dealer and have them solve the issue.

nuclrxn 11-14-2011 01:54 PM

Thanks, guys. Also, the noise I hear when I don't hear the "horn" is a deep breathing noise; kinda like I have a CAI installed. I'll upload a video.

SurlyOldManMN 11-14-2011 06:41 PM

Yup, sounds about right.

Subie2012 11-17-2011 12:24 PM

I do have the same issues...not always though..on highway.....I have 1800 miles on it..

nuclrxn 09-10-2012 08:39 AM

As a follow-up, I'm at 16,000 miles now and the noise is non-existent. The dealer reseated the intercooler and gaskets, as suggested by SurlyOldManMN, at around 3,000 miles and that did the trick. Thanks, fellas!

nuclrxn 12-01-2012 10:40 PM

Well, after being absent for so many miles and months, the horn noise decided to come back. Boo. I'm at 19,800 miles. WTH.

SurlyOldManMN 12-02-2012 10:34 AM

You need to REMOVE those gaskets, not reseat them. $10 says you have the exact same issue you had before.

SurlyOldManMN 12-02-2012 10:41 AM

btw, you can do this yourself in 15 minutes or less. I can do it in 5-10 minutes using nothing more than a socket wrench and my ham hands comprised entirely of thumbs. Just make sure you note the position of the IC->TB coupler before you pull everything apart. It's annoying to find the right angle and you won't know until it's almost completely back together.

AZP Installs 12-02-2012 05:10 PM

Quote:

Originally Posted by nuclrxn (Post 4182619)
Well, after being absent for so many miles and months, the horn noise decided to come back. Boo. I'm at 19,800 miles. WTH.

Have the dealers replace those gaskets. That's what warranty is for :)

-Mike Paisan

http://www.pbase.com/paisan/image/91072632.jpg http://www.pbase.com/paisan/image/14...8/original.jpg http://www.pbase.com/paisan/image/133406601.jpg http://www.whiteline.com.au/images/logos/perf1.jpg
11+ Years Maintaining, Modifying and Educating TriState Subaru Enthusiasts.
Call directly as We carry almost every manufacturer now, so before you buy parts call us.

Like us on Facebook! | E-mail: sales@azpinstalls.com | 725 Fairfield Ave | Kenilworth, NJ 07033 | 908.248.AZP1 (2971) | T-1 Certified Amsoil Direct Jobber |AIM: AZP Installs
"Race Tested, Enthusiast Approved!"

nuclrxn 12-03-2012 10:17 AM

Quote:

Originally Posted by SurlyOldManMN (Post 4182899)
btw, you can do this yourself in 15 minutes or less. I can do it in 5-10 minutes using nothing more than a socket wrench and my ham hands comprised entirely of thumbs. Just make sure you note the position of the IC->TB coupler before you pull everything apart. It's annoying to find the right angle and you won't know until it's almost completely back together.

I'll be doing this tonight. Thanks for the tip, SurlyOldManMN. F the dealer this time around.

nuclrxn 12-04-2012 10:14 AM

2 Attachment(s)
SurlyOldManMN was right. Took less than 10 minutes to do this; 15 actually because I wanted to clean out some leaves and junk. Besides, it's very satisfying to take stuff out of the car. :rolleyes:

The rubber gasket is really soft and pliable, so it's no wonder it folds in on itself. Here's a shot of the engine bay with the IC and hose gasket taken out.

Sound issue resolved! Thanks, guys.


All times are GMT -6. The time now is 07:25 PM.


LegacyGT.com