Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fifth Generation Legacy (2010 - 2014 ) (http://legacygt.com/forums/forumdisplay.php?f=92)
-   -   Just Got This Notice From Subaru Care? (http://legacygt.com/forums/showthread.php?t=163181)

Almatti 05-31-2011 08:33 PM

Just Got This Notice From Subaru Care?
 
Service Program WVU31: WVU31 Reprogram ECM

Subaru Care sent via email. Is there a TSB about Reprogramming the ECM on 2.5i 2010 Leggies? What is that For? Thanks for the info. This forum is great !!

FLZ_Boy 05-31-2011 10:20 PM

It's suppose to help improve emissions, but you never know what you going to get..................

Link for TSB discussion on ECM: http://legacygt.com/forums/showthrea...re-158741.html

Almatti 06-01-2011 08:21 PM

Thanks for the head's up. I'll Pass. My Leggie is running perfectly well with 14k on the clock. Bought it as a CPO in February 2011 with 7400 miles. When It Ain't Broke......Don't Fix It!!!

JAVAR LGT 06-01-2011 09:09 PM

Hmm I haven't get anything yet.
I bought my 2010 LGT limited as a CPO with 5700 miles, currently 8045 and running great. I'll pass as well.

ehsnils 06-02-2011 12:39 AM

They may have been required to do that by EPA or something, but if you never take in the car to the dealer for service then you shouldn't worry about getting it if you don't want it.

LongHiway 06-02-2011 02:50 PM

Wife and I have an '05 and '06 - both were recalled to have the ECU re-programmed, about a year apart. Something to do with the temperature of exhaust gasses in the cat. Wonder if Subaru is changing this for all models?

ihatecrashing 06-03-2011 09:02 PM

They just did that upgrade on mine last oil change. Haven't noticed anything different. Yet.

mclovin 06-03-2011 09:41 PM

i think i still have to do that to mine but i know that some people were having issues with idle revs dropping out and things like that. i've had the issue for some time but what i've been told they have known about this TSB for a while so from what i can assume most 2011 probably wont have the issue...other then that i have no idea what that ecu update does or is supposed to do...

FLZ_Boy 06-03-2011 11:47 PM

I think it probably would fixed some the emission annoyances the earlier NA models had, especially with the manual transmission.

I remember 08 Impreza 2.5i 5-Speed Manual would have rev hangs before it would drop, idle would die a little and then the ECU would prop it back up. I think also it might be some of the cause of the low speed bucking I would get.

Compared to my 11 Legacy 2.5i 6-Speed Manual, I don't get rev hangs (just maybe if I wind up 1st gear - more of a heavy flywheel weight), the bucking is very subtle, and idle may dip once in a great while.

Almatti 04-28-2013 10:41 AM

The recent service dealer applied this reflash per the TSB. I didn't authorize it. Now I think there is a little less smoothness at idle? Is it my imagination. Even though this Update was pending for over a year, I asked NOT to have it applied. If It Ain't Broke, Don't Fix It... But this time without consulting me, the Dealer did it. I didn't notice it until I paid and reviewed my bill. There was N/C but I fear the electronic changes. Anybody have experiences with the new upgrade to their 2010?

coppertone 04-28-2013 11:08 AM

I had it done against my knowledge by the dealer and my car felt like a slug afterwards.

GTEASER 04-29-2013 10:16 AM

Quote:

Originally Posted by coppertone (Post 4408877)
I had it done against my knowledge by the dealer and my car felt like a slug afterwards.

That's because the ECU was reset and it needed to re-learn your driving style and typical throttle inputs. Whenever the dealer resets the ECU, always drive it like you're possessed for first 20 miles after reset, and it will adjust to you.

Depending on your State, you may be required to have this service done in order for you to register your car this year. This was the case with my 2012 LGT when the WQC-39 came out. The State was notified because this was emissions related, and I would not have been able to register the car again in July if this had not been performed.

Ellesedil 04-29-2013 12:23 PM

Quote:

Originally Posted by GTEASER (Post 4409931)
Depending on your State, you may be required to have this service done in order for you to register your car this year. This was the case with my 2012 LGT when the WQC-39 came out. The State was notified because this was emissions related, and I would not have been able to register the car again in July if this had not been performed.

Ditto for Mass. My car is actually serviced in NH (not required) so I had to ask in order to get the ECU update. Figured I might as well anyway as I'm not tuned yet.

subiebeast22 04-29-2013 01:43 PM

I had this done on my 06 2.5i and I didn't notice a difference at all. Car saw 90 highway so there wasnt a whole lot off accel to see if it felt sluggish.

LongHiway 04-30-2013 08:24 AM

Quote:

Originally Posted by subiebeast22 (Post 4410303)
I had this done on my 06 2.5i and I didn't notice a difference at all. Car saw 90 highway so there wasnt a whole lot off accel to see if it felt sluggish.

Ditto my experience on an '05 2.5i.


All times are GMT -6. The time now is 06:59 AM.


LegacyGT.com