Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Second Generation Legacy (1994 - 1998) (http://legacygt.com/forums/forumdisplay.php?f=95)
-   -   1996 Legacy L wagon. Fuel pump won't work (http://legacygt.com/forums/showthread.php?t=125506)

metro604 11-21-2009 07:32 PM

1996 Legacy L wagon. Fuel pump won't work
 
I have a a 1996 Legacy wagon 2.2. It died yesterday while driving it down the street. I didn't hear the fuel pump when I turned the key and also took off the fuel line at the filter input and found it was getting no gas. So I figured fuel pump. Right? Wrong..... I replaced the pump today and it still does not come on. The engine cranks just fine, I have plenty of gas. All fuses appear to be good. There is power to one of the wires to the fuel pump. I assume a couple of them are ground and/or also going to a sending unit? I guess my question is: Where do I go from here? Is there a relay in line or a crank sensor that may control this? Or do I assume that the computer is having issues? It did kick a couple times when I used starting fluid in the intake yesterday. Anyway, your help/advice is appreciated..Thx

sparky78 02-27-2013 12:44 PM

the fuel pump relay is located left of the sterring wheel,deep up under the dash,it is green, and is next to the ingnition relay which is brown, the relay is round in shape.

pleaidestar 02-27-2013 05:32 PM

Hey bubba, this thread is a few years old. Did somebody bump this?

sparky78 03-02-2013 11:00 AM

fuel pump relay cuts out
 
:confused:my 96 legacys fuel pump comes on at start but then cuts out, I know the relay is working, but what controls the relay? would it be the ECM? any help would be awesome....:confused:

pleaidestar 03-02-2013 11:33 AM

Fuel pumps that are failing sometimes will do that, does it start everytime you try it? Need more info on your problem. There is a relay bypass thread that might be of service to you..it will let your pump run so you can determine that area. Fuel system is rather simple..not too many technical components.

Some issues that cause your symptoms:
Poorly functioning fuel pressure regulator (not common)
Plugged egr tube or valve body (cars equipped with 4eat only)
Egr vacuum solenoid/switch (4eat only)
Cam position sensor
Crank position sensor
Fuel pump relay (you said it works)
fuel pump (complete failure could take time)
Ignition coil

Etc.....there are people here that can chime in that know more.

snederhiser 03-02-2013 08:30 PM

Hello;
Have you replaced the fuel pump, or even pulled it to inspect? The relays are quite robust on these cars and would be towards the bottom of the list. A fuel pump can run then stall. I pulled mine determined the pump was good but replaced the sock (filter). Ran this off my battery charger and was only pulling 3 amps. Also did a pressure test, Steven.

sparky78 03-03-2013 11:17 AM

I have pulled the pump to check,it all seems good, and the pump is only about a year old, when i turn on the key i hear the relays close, and the pump will run for about 2-3 seconds, and the the relay opens and the pump stops, it will do this every time i turn on the key, so i guess i need to know what controls the fuel pump relay to just drop out and stop providing power to the pump.

snederhiser 03-03-2013 08:53 PM

Hello;
I had this same probelm! You will need to pull the relays and check them with a power source (battery/charger) and an ohm meter. Check all three relays, fuel pump, engine management, and main. Leave these hooked up for 5 minutes. Also check your ignition switch and both connections to the starter. If the ECU does not get the correct signal from the starting circuit, it will shut off the fuel pump relay. Hope this helps, Steven.

sparky78 03-04-2013 06:32 AM

i will check these and get back to you, all help is greatly appriciated!!!


All times are GMT -6. The time now is 12:56 PM.


LegacyGT.com