Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Stage 1 ACN Burning Smell (http://legacygt.com/forums/showthread.php?t=197390)

O.C.D. 12-05-2012 03:00 PM

All of my Subarus smell like that, lol. Hell even my '80 Brat smells like that.

I thought that was a factory option - the "I had fun with you Subie" smell.

rob-2 12-05-2012 04:41 PM

Quote:

Originally Posted by O.C.D. (Post 4188209)
All of my Subarus smell like that, lol. Hell even my '80 Brat smells like that.

I thought that was a factory option - the "I had fun with you Subie" smell.

If there is nothing to worry about, I'm fine with it. However I suspect something is burning or a grease is underspec'd for temps. Both would be bad.

Max Capacity 12-05-2012 04:51 PM

FWIW, neither of my cars have the engine cover.

So it sounds like you know your way around the car. If you've checked it over and under and don't see anything that looks like its burning. Just drive it.

FJuan 12-05-2012 04:53 PM

Leaking Valve cover, leaky intercooler would also cause this.

doobaruGT 12-06-2012 07:22 AM

FWIW, I was just as concerned as you and very skeptical of the "subie smell", thinking cars shouldn't smell like they're burning regardless. However, I ran my car reasonably hard (no red lines but heavy load accel, corner g's and braking) two days ago on a long drive home and whaduyaknow....the burning smell is gone. I can't explain it but it is no more. maybe these guys are right. I have to do IM gaskets and an oil change this Saturday so I'll let you know if I come across anything suspicious.

JMLegacy 01-13-2013 09:33 PM

For my leak it was the valve body and cam angle sensor gasket.. I got that repaired on thursday last week.

Izzy_ 01-13-2013 10:49 PM

I know you say burning smell but still, check also steering pump for leaks. Friend of mine has an 05 gt and it turned out to be that. :)

rob-2 01-14-2013 12:24 AM

Quote:

Originally Posted by doobaruGT (Post 4189219)
FWIW, I was just as concerned as you and very skeptical of the "subie smell", thinking cars shouldn't smell like they're burning regardless. However, I ran my car reasonably hard (no red lines but heavy load accel, corner g's and braking) two days ago on a long drive home and whaduyaknow....the burning smell is gone. I can't explain it but it is no more. maybe these guys are right. I have to do IM gaskets and an oil change this Saturday so I'll let you know if I come across anything suspicious.

Did you come across anything?


All times are GMT -6. The time now is 06:00 PM.



vBulletin Optimisation provided by vB Optimise v2.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
LegacyGT.com