Subaru Legacy Forums

Subaru Legacy Forums (http://legacygt.com/forums/index.php)
-   Fourth Generation Legacy (2005 - 2009) (http://legacygt.com/forums/forumdisplay.php?f=10)
-   -   Burnt Oil Smell in Cabin (http://legacygt.com/forums/showthread.php?t=196717)

gessvt 02-19-2013 07:04 AM

I've done an easy experiment on my own, and it seems to have greatly reduced the burnt oil smell in the cabin after longer drives. I used to top off my oil to the small hole above the "F" on the dipstick. In the past few weeks I've tried to keep it at the "F" instead. Using Rotella T6 fwiw.

rhumb line 02-19-2013 07:45 AM

Quote:

Originally Posted by sigmafour (Post 4299181)
Found a walkthough for you here:

http://sl-i.net/FORUM/viewtopic.php?t=12784

Hopefully it will allay some of your fears.

Thanks for the information-- I'll get more familiar with the the site and be better able to find things. Thanks for your help!

I have done a lot of work to the car myself. I have an excellent workspace and all the tools that I'll need. I know from experience that there are always little tricks that help make the job go easier. There are also the 'gotchas' that you want to be aware of. I have some great information from my last vacation as well.

Now all I need is the time and peace to get it done.

Thanks again.

Shello007 05-04-2013 10:54 AM

Quote:

Originally Posted by gessvt (Post 4300520)
I've done an easy experiment on my own, and it seems to have greatly reduced the burnt oil smell in the cabin after longer drives. I used to top off my oil to the small hole above the "F" on the dipstick. In the past few weeks I've tried to keep it at the "F" instead. Using Rotella T6 fwiw.

I drained my oil yesterday after consistently dry dipstick during readings. I ended up with approx. 3.5 quarts- this after topping up with about 2 quartz for the past month. Where the hell is my oil going? Getting faint burning scent, after spirited driving. Boot has long been replaced, Coolant also swishing around in heater core ( all hoses and radiator caps replaced)..This is really beyond vexing me right now.:mad:. And FWIW, I religiously use Rotella T6. Question I have is, Could possible head gasket change be needed?

chato 05-04-2013 01:37 PM

you check the pcv?

Shello007 05-07-2013 03:24 PM

^, nope...will do

rob-2 05-07-2013 03:28 PM

Quote:

Originally Posted by Shello007 (Post 4421118)
^, nope...will do

I replaced mine and my oil consumption dropped from 1qt per 900 miles to somewhere in the area of 1qt per 5k.

scoobycoupe 05-07-2013 05:45 PM

anyone have a pic handy of where the PCV is located?

Shello007 05-07-2013 07:16 PM

Quote:

Originally Posted by scoobycoupe (Post 4421293)
anyone have a pic handy of where the PCV is located?

http://legacygt.com/forums/showthrea...t-95003p7.html

Quote:

Originally Posted by rob-2 (Post 4421121)
I replaced mine and my oil consumption dropped from 1qt per 900 miles to somewhere in the area of 1qt per 5k.

Thanks. Me thinks that's the culprit.

MAP 05-08-2013 08:01 PM

Quote:

Originally Posted by rob-2 (Post 4421121)
I replaced mine and my oil consumption dropped from 1qt per 900 miles to somewhere in the area of 1qt per 5k.

rob-2,
Do you recall what condition the pvc that you removed was in? Does it have a spring loaded check valve or does it just have a small diameter tube? Thanks.

rob-2 05-08-2013 10:00 PM

Quote:

Originally Posted by MAP (Post 4423219)
rob-2,
Do you recall what condition the pvc that you removed was in? Does it have a spring loaded check valve or does it just have a small diameter tube? Thanks.

I replaced an entire black part and didn't see the valve itself. It's a ball bearing setup and the new one rattled just by looking at it. The old one was gummed up and didn't rattle much.

gessvt 05-09-2013 08:44 AM

I found a part number for a Subaru OEM PCV that is 11819AA001. I did a compatibility check for one of these listed on eBay but LGT's are not listed. Anyone know if this is the correct part for a 2005 LGT?

06silvarubiLGT 05-09-2013 09:04 AM

it may be the same as the 08+ STi ones since most of the intake set-up is the same, but Im not sure PM underdog, he can get you the OE numbers

Shello007 05-09-2013 05:09 PM

Got my new PCV set up today. Attempted to do it myself. I Saw those factory clamps...and the location of that set up and I was like WHOA!!! A lil help anyone, Please...


All times are GMT -6. The time now is 10:46 PM.



vBulletin Optimisation provided by vB Optimise v2.6.3 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
LegacyGT.com